Please Help me with my Blu-Ray burning problem (LG GGC-H20L)

[qanda]This thread is about the LG GGC-H20L. Click here to see full specs[/qanda]I just got my blu-ray burner an LG GGC-H20L which came with an LG BD-RE 25GB single layer Blu-Ray disc. I ripped a blu-ray movie via AnyDVD HD and used ImgBurn to burn it to my media. I used all the appropriate settings and the burn was successful. Now when I load it into my PC Blu-Ray player, the movie reads and shows the Paramount’s Hi-Definition screen, and then after that screen it stops and nothing else pops up. I can’t get to the movies menu select screen or any other screen for that matter. I tried the disc in my Ps3 and the same happens. The paramount Hi-Definition screen plays and then the screen goes blank. I have no idea why this keeps happening and was wondering if any of you had any ideas or have had this happen to you. It just seems like it won’t access any additional chapters on the disc. Thanks for your help.

On a side note: I tried playing the m2ts files straight off my HD and they work. I also tried playing the m2ts files off the BD-RE disc via windows explorer and they also work! So the movie burned fine. :confused:

I see that your question is answered here http://club.cdfreaks.com/f142/backup-your-blu-ray-movies-guide-backupbluray-208395/index4.html#post2154536 :wink: