Please help me unbrick sansa!

i’ve spent quite a while trying looking on forums for answers and hope you guys can help me out.

I own a sansa c250 01.00.06P which I somehow recently bricked by downloading the newest version of rockbox. By bricked, I mean that whenever I turn on the player, even when pressing the left button, a dark blue light fills the screen & the screen goes black after several seconds. I followed the rockbox instructions & ended up having to copy the .mi4 & .rom files on the recovery mode folder of the player. After that, the sansa firmware was working, though the sansa dragon & mp3 player logo looked somewhat different & the sansa firmware took longer on the player to boot. I installed rockbox, which allowed me to copy files & worked, playing mp3, some sort of photo files, & mpg files on the player. However, whenever I tried to delete files from the player using the player’s erase feature (though deleting them on the computer did give more space on the player), they still took up just as much space as if they were there when I checked for total amount of space on the player in the player’s & window’s ways of finding totall space on the player. i’ve reinstalled rockbox but still have this last problem & the problem of the sansa firmware taking about a minute to boot (& the dragon & sansa player logo still looks different than usual). somehow, while using the rockbox firmware on my player (i think it was once when i was using it when i turned the player on & off when the problem developed) the files were no longer able to be accessed on the rockbox firmware & now whenever i use my sansa player i must take the longest time to boot my player & must cope w/ using the sansa firmware to play only my mp3 files.
Please help me out!

i think you might have had issues due to copying a .rom file there… according to there site it looks like your never supposed to copy a .rom file to the recovery partition.

ONLY copy .mi4 files to it!

i assume you went here… http://www.rockbox.org/twiki/bin/view/Main/SansaE200Unbrick …and followed those instructions?

http://daniel.haxx.se/sansa/c200/firmware.mi4 (c200 v1.00.06) … looks like thats the original firmware file they give you in there recovery part… so basically go back to recovery mode and ONLY copy that file to the recovery partition and then see what happens.


Recovery mode can be used to replace a bad .mi4 image on the player. If you by some reason can’t boot into the original firmware, like if you messed up the installation or similar, you can boot into the recovery mode as follows:

* Power off
* Turn ON lock/hold
* Hold down record
* Hit Power/Menu Button 

You will find a 16MB USB drive now, this is the recovery partition.

A word of caution WARNING

* [B]Only copy .mi4 files to the recovery partition.[/B] Note: If you have an e200 series, you might have to rename the .mi4 to PP5022.mi4 if it is not named that already. [B]If you have a c200 series, you might have to rename the .mi4 to firmware.mi4 if it is not named that already.[/B]
* Do not format this 16MB drive
* [B]Do not copy anything except one .mi4 file to the recovery partition. This might turn your shiny toy into a paperweight![/B]
* [B]Do not copy .rom, .btl, or .bin files to that partition unless you know exactly what you are doing. Again: You might brick your player![/B]
* Do not interrupt a file transfer or running operation. Again: You might brick your player!
* Do not try anything else unless you have to. Again: You might brick your player! 

You have been warned.

and also… after your original firmware is restored… i would completely DELETE the “.rockbox” folder from the root of your player… then reinstall the bootloader and then copy the “.rockbox” folder back into the device just to make SURE your Rockbox copy is in good running order.

p.s. i have a e250 myself so i got a general idea on what your supposed to do but since you got a c200 it might be a little different but i think it’s basically the same as i had to recover mine once but it was basically completely my fault and NOT Rockbox’s as i was messing with crap i was not supposed to do… but now im good :wink: … but basically when mine was semi-bricked (i.e. constant reboot cycle) i went into ‘recovery mode’, copied the .mi4 file to it… disconnected the USB cable and it rebooted and it did it’s thing and the player was working good again and then i just installed Rockbox back onto it.

thanks so much for your response.
yes, i followed all of rockbox’s instructions on the unbrick page (& when i originally installed rockbox on this problematic player-the other 3 times i installed it on earlier sansa c250’s there were no problems so i doubt i was to fault this time) & only copied the .rom file when copying the .mi4 file to the recovery drive of my player didn’t make my player work. pending on your response to the following question, i’m probably going to download linux & redownload rockbox after using the erase method which is described on the rockbox page you linked to in your last message. is it possible for me to dl linux or the mac operating system on my windows operating system whilst having the ability to switch back & forth b/w operating systems?
thanks

well MAC stuff is ONLY for Mac hardware pretty much… but Linux can run on your typical Windows PC. (you might even be able to run Linux in a Virtual PC with programs like VMWare or VirtualBox ( http://www.virtualbox.org/wiki/Downloads ) etc (i never actually used VirtualBox myself though) )

but i think it’s possible to switch between windows and linux OS’s as i think most linux crap allows you to setup a dual boot between windows and linux but off the top of my head i dont know the details as i have minimal experience with Linux myself.

but since you said this… “when i originally installed rockbox on this problematic player-the other 3 times i installed it on earlier sansa c250’s there were no problems”

that comment right there almost makes me wonder if the c200 series device you have has faulty hardware to begin with. :frowning:

EDIT: i was looking around some more… appears you might even be able to use a ‘Linux Live-CD’ to do stuff but im not 100percent sure.

i guess i’ll get to work on the linux-thanks a lot

it ended up being easier for me to get a new 20$ player (everything the same except it’s 1.00.05p instead of 1.00.06p) which works w/ rockbox, though i dothank you for all the help you gave me w/ my old player.

a while ago i bought a 4 gb sansa sdhc, which i have trouble getting to be seen on the computer so i can put files on it, though the storage card does comes up as a 4 gb card on my mp3 player. i did some research & i know that rockbox has been working on a solution to the problem. do you know if there’s a way for my card to be recognized on my comp so i can put files on it?

thanks in advance

@ techtic … there is already USB and Battery Charging support for the e200 series and im pretty sure the c200 series works to (since it has new bootloaders for it to)… which means you can directly transfer files to a MicroSDHC card from windows explorer instead of having to use Rockbox itself to transfer from internal memory to the external memory.

but basically with a ‘current build’ of rockbox… Windows Explorer (or My Computer) should show 2 different drive letters. the drive letter after the main one for your c200 should be the MicroSDHC slot. (so in other words… if your c200’s internal memory is E drive then most likely F will be the MicroSDHC slot)

just use a recent build of rockbox (i.e. ‘current build’) and if you want the player to stop loading the original firmware when plugging in the USB cable… use the new bootloader for it which you can get here… http://www.rockbox.org/tracker/task/9955

i use that myself on my e200 and it works great…

to install you need to get the sansapatcher.exe file and do a ‘sansapatcher.exe -a firmware.mi4’ (without the ’ ) (that’s for the c200 series… just use the file from the c200 folder in the .zip file you download from the link i gave you above)

but basically get a ‘current build’ of Rockbox and then get that up and running and you can use it’s USB support to do the ‘sansapatcher.exe’ stuff i talked about in the above sentence.

once you do all that stuff above… when your device is OFF and you plug in USB cable to device and then connect it to the PC it will boot into Rockbox now instead of the original firmware. to boot original firmware you still press and hold the left button while powering on as usual.

or if you dont want to mess with the bootloader just install a ‘current build’ of Rockbox and then USB should still work fine… it’s just the bootloader disables original firmware from loading which is what i would do since the original firmware aint needed now since it does USB/Battery Charging which was all Rockbox was lacking that the original firmware had but not anymore :wink:

p.s. it a little late now, but for a little over 20 bucks (probably 30 range) you could have gotten a e200 series for not much more and it’s just flat out better than c200 series in my opinion since it’s fancier and has a bigger screen etc.

thanks for the tip about the comp recognizing the player as a drive even when the player isn’t running w/ the sansa software-it worked w/ the latest version of rockbox i’ve installed.

about the storage card being recognized as the next drive after the player (ex. player-e, card-f), it didn’t work neither when i plugged the player in the comp when it was off nor when i plugged it in when the sansa software was running. i think the reason is b/c the card i have isn’t a normal sansa sd card but it’s a sansa sdHC card, & the old players don’t have a software configured to support the new sdHC software. do you know if rockbox or anyone else put out a software that would run my 4 gb sdHC card on my player?
thanks

your MicroSDHC card should work for sure in Rockbox.

i have a e200 series that normally cant support MicroSDHC cards but with Rockbox it works perfectly fine as i can directly transfer files to the MicroSDHC card (i have a 8GB MicroSDHC card myself) from Windows Explorer where as with stock firmware the player supposedly dont support over 2GB MicroSD cards.

are you using a ‘current build’ of Rockbox? … if not, update that to a ‘current build’ ( http://build.rockbox.org/ ) … once you got a current build installed and Rockbox is up and running then connect the USB cable to the PC and Rockbox should find both the internal memory and external memory (i.e. MicroSDHC) they should be listed as drive letters in Windows Explorer. (im guessing the c200 is the same as the e200 in this sense)

as for when you said… “it didn’t work neither when i plugged the player in the comp when it was off nor when i plugged it in when the sansa software was running.” … MicroSDHC cards wont work for sure with the original sansa firmware but they do work when rockbox is running… as for when the device is OFF and you power it up from the USB port that wont work either because right now your device will automatically boot into the original sansa firmware which is what that ‘bootloader’ i talked about in my above will take care of. once the new bootloader is installed it will make it boot into Rockbox instead of the original firmware when the device is off and you power it on through the USB port.

so basically what im saying is this…

1.Install Current Build of Rockbox to your c200 series device which you can download here… http://build.rockbox.org/
2.Install that copy of Rockbox to your c200 device.
3.once it’s installed to the device… make sure Rockbox is loaded up to it’s main menu.
4.Connect USB cable.
5.Windows should detect it and then you will see a USB cable icon type thing on your C200 screen.
6.Use windows explorer (or My Computer) to access the drive letters of the Internal Memory & External Memory (i.e. MicroSDHC card)
7.Transfer files to it. :wink:

that should sum it up.

p.s. right now i have a total of 10GB (2GB internal + 8GB MicroSDHC) … and Rockbox works perfectly fine with the 8GB MicroSDHC slot.

worst case scenario is this… if you cant get the 4GB MicroSDHC card to work, you still should be able to use Rockbox itself to transfer files from it’s (the c200 series) internal memory to the MicroSDHC slot using it’s ‘copy and paste’ function :wink: … i know this aint the most efficient way of transferring files to your MicroSDHC card but it will work. (but like i say a ‘current build’ of Rockbox should have USB working fine which will allow you to directly transfer files from your PC to the MicroSDHC card from Windows Explorer)

i followed your instructions & plugged in my sansa when the rockbox firmware was loaded &, though the F folder (the player was recognized as the E folder) showed up on my computer, when i tried to open it, the comp said “please insert a disk into frive F.” when i plugged in my player when the rockbox firmware was loaded, the USB icon came up on the screen for a sec & then the normal sansa “connected” screen came up. After i unplug the player from the comp, after the “refreshing database” screen stops showing, the player returns to the sansa firmware. Maybe i’m doing something wrong in connecting it or otherwise the USB icon will always be showing on my player’s viewing screen as long as the player is connected & once i disconnect it it’ll go back to the rockbox firmware i connected it in :confused:

thanks a lot

my guess is your player is programmed to default to sansa firmware when it detects USB connection. (this is what it sounds like based on what your telling me)

the cure = use the updated bootloader here… http://www.rockbox.org/tracker/task/9955 (which i talked about in my post above) … [B]just make SURE you use the c200 file (i.e. in c200 folder called ‘firmware.mi4’) when updating the bootloader otherwise you could semi-brick your player!!! (THIS IS IMPORTANT!)[/B]

so once connected through the original sansa firmware do a ‘sansapatcher.exe -a firmware.mi4’ (without the ') and it will write the new bootloader to your c200 device which should stop your player from booting into the original firmware every time the USB connection is connected. (here is the sansapatcher.exe file… http://download.rockbox.org/bootloader/sandisk-sansa/sansapatcher/win32/sansapatcher.exe ) … so basically just do this… copy the sansapatcher.exe file along with the firmware.mi4 file to your C on your PC and then go to “start > run” and type in CMD and hit enter (you should be at a DOS prompt) once there do a “CD” (without the ") and hit enter, then do the ‘sansapatcher.exe -a firmware.mi4’ (without the ') and it should take a few seconds tops and it should either say something like success or go back to prompt… once it does that safely disconnect the USB cable and then power off device and power it back on… then try loading up Rockbox and then connecting the USB cable… does it still load the sansa firmware? (it should not anymore now :slight_smile: )

but just to see if your player is even recognizing the MicroSDHC card you can attempt to ‘copy and paste’ a file to it from within rockbox… just go to ‘files’ on main menu and find a file on the internal memory and then once it’s highlighted press and hold the select for a second or so and another menu will come up then just select COPY then go to ‘microSD1’ (that’s what mine is on my e250 and im guessing yours should be roughly the same) and then once in there press and hold select again and select PASTE this time… it will then copy the file from the internal memory to your MicroSDHC card.

but if that works then Rockbox definitely works with it… but based on what your telling me im almost sure it’s a bootloader issue… because your basically telling me that when rockbox is loaded up and you connect the USB cable that your c200 device boots back into the original sansa firmware? … if it does then you need to use that bootloader and it will stop it from booting into the sansa firmware when using the USB cable.

i tried everything you said & installed the sansapatcher & the bootloader, put them in my c folder, & then went to start, then to run, typed in CMD, typed in CD/, & typed in sansapatcher.exe -a firmware.mi4 & it neither said “say something like success or go back to prompt-” instead it said some phrase which meant that it didn’t work. i also opened the sansapatcher file & loaded the bootloader (which it automatically prompted me to do, so i suspect it wasn’t the .mi4 bootloader), which worked. i unplugged the device, turned it off & on, & plugged it in when the rockbox firmware was running, & still i saw the sansa logo when it was charging.
please help me, as this whole thing is getting very annoying for me.

Thanks!

did you do this on your original firmware before doing the ‘sansapatcher.exe -a firmware.mi4’ stuff…


The following steps require you to change the setting in [B]Settings → USB Mode to MSC from within the original firmware.[/B]

because your device MUST be setup like that in original firmware (i.e. the sansa firmware) otherwise the sansapatcher stuff i mentioned wont work for sure.

so was your c200 setup in MSC mode before doing the sansapatcher.exe stuff?

but basically make sure the sansapatcher.exe and firmware.mi4 are in the root of your C drive when doing the ‘sansapatcher.exe -a firmware.mi4’ stuff.

p.s. you also have to have administration rights on WindowsXP or Vista otherwise you cant run the sansapatcher.exe properly! (but i just assumed you do)

as it says this on there website…


Administrator/Root rights.
Installing the bootloader portion of Rockbox requires you to have administrative (Windows) or root (Linux) rights. Consequently when doing either the automatic or manual bootloader install, please ensure that you are logged in with an administrator account or have root rights.

most likely you have your administration rights setup properly since you installed rockbox in the first place which requires changing the bootloader.

and also… just checking obvious here but you did get this file… “bootloaders.zip (421.3 KiB)” right? (because inside that file is the c200 folder which contains the firmware.mi4 file you need which changes the bootloader)

and also… does your Rockbox boot up to the main menu? (if not, make sure it does that because some people say there’s issues with USB being detected if your in the DATABASE menu when Rockbox first loads up.)

also it might be a good idea to completely delete the “.rockbox” folder from the root of you c200 player and install a fresh copy from the ‘current build’ section on there website… just to make SURE Rockbox itself is in good running order. (NOTE: you will lose all your settings you have adjusted in Rockbox but i would still do this just to be certain Rockbox itself is in proper running order) … and [B]you cannot use the v3.2 stable build of Rockbox since USB is disabled in that!!![/B] … just make SURE your using a current build.

is there any way to turn off the usb mode to msc not within the sansa firmware running b/c there was no option of switching to usb on my player (i’ve seen the option available sometimes on my mp3 player in the past & i know the option should be in settings but now it’s not there) & when i plugged in the player w/o pressing hold & the left button it still registered as in usb mode

well if that MSC mode is not available in your original sansa firmware the first thing i would probably do is downgrade to a different version of the original sansa firmware and then reinstall rockbox.

they have different original firmware files for your c200 series here… http://daniel.haxx.se/sansa/c200/firmware.mi4 (that’s v1.00.06)

they have more here if you need them… http://files.zefie.com/PMP/sansa/c200/v1/firmware/ (but the one above should be fine) (also depending on where you live the A = America … E = Europe) (if you aint sure what one you need you can check your current firmware version and find out if it’s A or E :wink: )

because im guessing your current original sansa c200 series firmware happens to be one of those versions that dont allow you to select the MSC mode etc that’s needed. (i dont know details but i have heard certain original sansa firmwares dont have those options)

you can probably use your devices ‘recovery mode’ to flash to a different version… just be careful!

here is the link to recovery mode… http://www.rockbox.org/twiki/bin/view/Main/SansaC200Port

but basically…


Recovery Mode

Recovery mode can be used to replace a .mi4 image on the player. If you by some reason can’t boot into the original firmware, like if you messed up the installation or similar, or you simply want to change the firmware to a different version, recovery mode can be your friend. To get there:

* Power off
* Turn ON lock/hold
* Hold REC button and press MENU button (used to turn the player on/off)
* Plug the player to the computer
* In My Computer you can see new drive 16MB-FORMAT 

To update the firmware, copy the unzipped files into the 16mb drive, unplug the player, and release the hold switch.

[B]A word of caution WARNING

* Only copy these specific files to the recovery partition.
* Do not format this 16MB drive
* Do not try anything else unless you have to. Again: You might brick your player! [/B]

If all else fails, you can try the SansaC200Erase tool to completely wipe your Sansa clean in order to recover it.

so basically when in ‘recovery mode’ copy the firmware.mi4 file (http://files.zefie.com/PMP/sansa/c200/v1/firmware/1.01.06/SansaC200A1_01_06.7z (it’s in .7z format so you will need www.7-zip.org to extract the .mi4 out of it) , if your in USA … check your current firmware version as it should most likely show either A or E in it etc) to the device when it’s in recovery mode and it will flash the player with a original firmware file and then your device will be back to stock. you will have to reinstall rockbox’s bootloader (which you need to change your player to MSC Mode FIRST!) etc etc to get rockbox up and running again.

but the basic point where trying to do is get MSC mode back onto your c200 player :wink: because without MSC mode you cant really do to much with your c200 as far as Rockbox and file transfers etc etc.

i tried your last step & simply got annoyed w/ all the work i did & all the work not even helping so i reverted to the cut/paste function w/ in rockbox :slight_smile:

i’m thinking of upgrading to the e200, like you recommended. does it use the same cable & battery as the c200? also, do you know where i can find tech specs on it (i’ve been having difficulty doing so)?

part of the reason i want to buy the e200 is that i’ve had issues w/ the earbud jack of the c200. after a few months of use, one of the earbuds, which works fine in my computer, only works in the player after i adjust the end of the earbud cord for a few seconds & after that i still have to adjust it several times while using it when it comes out (the right/left side always works while the other one has this problem). do you know whether there is less of this problem w/ the e200, any other mp3 players, or any other earbuds (mine were 6 $)?
thanks a lot

well i never owned a c200 myself so i cant say if the battery from the e200 fits into it but here is what the battery looks like for the e200… http://tinyurl.com/qjvr8d (it’s a ebay link)

as far as tech specs i dont know off the top of my head but i do know it’s Portal Player based and i believe it has 2 80mhz CPU’s in it in the v1’s (which is the only ones that can currently run Rockbox) where as the v2’s have a single 200mhz CPU but that’s currently not supported by Rockbox but it’s being worked on.

but here is a Wikipedia link on the Sansa e200 series as it talks about it’s history etc etc… http://en.wikipedia.org/wiki/Sansa_e200

but basically you can tell if the e200 player is a V1 or V2 by looking at the firmware version in it… v01.xx.xx etc it’s a V1 player where as the V2 players start with a v03.xx.xx etc.

the screen size on the e200 is basically about 2inches tall and about 1 and quarter inches wide (a little less than that actually but it’s pretty close on the width)

as far as the ‘headphone jack’ thing i cant say to much since as far as me personally it’s been working great for me and i owned the device for about 1 year right around now i got the device in June 2008 off Ebay… but i do tend to take care of my device pretty well as it’s not abused at all… but since you said you wiggle the earbuds… that’s probably the earbuds dying and not your player depending on what your doing to get it working etc. i think you can figure that out :wink:

p.s. i personally hate earbuds myself as i prefer headphones that go over your ear instead of inside it. but that’s just me :wink:

and also, you could try a recent build ( http://build.rockbox.org/) of Rockbox and see if it works with USB.