Please help me..NEC ND-6650A

Hello all,

Greetings! I recently bought a Dell laptop with NEC ND-6650A DVD±RW. I want to upgrade the firmware of the same optical drive.

I flashed the ‘Dell 202c OEM firmware’ published on http://liggydee.cdfreaks.com/page/6650/ at my own risk. It asked my confirmation to proceed. Unfortunately, i went on to risk.

When i restarted my computer the system was not able to detect any optical drives in the system. It implies ‘blank’ even when i saw in the system setup f2.

Please help me to restore my optical drive to its original state. i did system restore, but it was not so helpful.

:sad:

thank you cdfreak team

regards
saku

I wonder why everyone ignores warnings about inaccessible or broken drives and then starts crying for help. :Z
If your drive is not accessible, the only way you MIGHT be able to get it back to life is using an IDE adapter. You might also want to start reading here.

System restore won’t help you at all since this won’t install the old firmware on your burner.

Thank you for the kind help. I am not very good in handling hardware components. I just want to know the following,

  1. whether my drive is master or slave

  2. Which file i need to download NORMAL or REVERSE

  3. Wher do i need to type thisBT6650R6 /p:1 /d:1 /FWCHK:2

many thanks

saku

If your drive identifies with an 1* firmware, it’s a master device now, if it shows 2* you have a slave drive.

Normal is intended for master, Reverse for slave drives, but probably neither of them will be able to fix your drive.

The command has to be issued in real DOS mode (not a command window from within Windows) - but I highly doubt that it will work.

thank you liggy for the reply…

When i tried to execute BT6650R6 /p:1 /d:1 /FWCHK:2 or BT6650R6 /p:1 /d:0 /FWCHK:2 in the real DOS mode…I get the following error message

BUSY Time over

Firmware isn’t changed correctly

When i tried with 6650boot.bat, the following message gets displayed,

NEC - 6650a is not found.

Is there a sequential procedure that i can try…please help me…

Moreover, the optical drive le flashes when i restart the system. But, the drive is not detected in BIOS.

P.S. I didnt used any IDE adapter. I just used an external floppy drive on my laptop pc and attempted all the above.

thanks,
sadesh

Like I already said in this thread, there’s probably nothing you can do at all than buying a new drive. An IDE adapter might work, but don’t expect it!

I once read about short circuiting two pins on the drive, but I’m not sure if this will really help and I don’t remember which pins have to be used.

Thanks Liggy.

Dell asked me to send the notebook to their service centre. Will they be able to find that i messed up with firmware upgrades?

If they find it, will they rreplace with a new one? Or, will they charge me?

Moreover, my laptop is now under warranty coverage…

many thanks,
sadesh

I’m not sure if Dell will find out, but it is very easy to do this and by flashing this firmware you automatically lost the right to RMA you drive. You agreed to a disclaimer when you downloaded the firmware!

It’s likely they’ll charge you for this (and it’s their right to do this) since flashing firmwares that did not come from your drive manufacturer / OEM voids your warranty and there definitely is no official 202c firmware for this drive.

once again this is an issue caused by someone not taking the time to even read anything and assuming that 2xx firmwares are newer than 1xx firmwares and that is not true

Dell drives all use the 1xx firmware. flash it with the proper 1xx dell original firmware from the site and it will fix it.

Hi Phreak,

i regret for my mistake. Could u please explain the procedure by steps to recover this problem?

many thanks,
sadesh