Please help me, i have problem with burning

i have mashita dvd-ram uj-831S in my laptop.

Anyway, this burner worked fine for a year and it started not working
suddenly. so i sent to the support center, they said it is software problem and not hardware problem.
and it worked fine after they returned to me.

the problem is…now it’s not working.
it does read media (dvd rw and dvd-r and everything) (actually sometimes, it does not read media once in a while)

but it wouldn’t burn (both dvd+r and dvd+rw).
i bought new verbatim dvd+r to test if this is working, and it didn’t work.
it would gave me error message when i try to burn.
also interesting thing is when i insert dvd+r and see my computer
it says CD DRIVE instead of DVD+R. but when i test with DVD identifier
it says the disc is mitsubishi MCC 004.

my burning software is cyberlink power2go.
i have daemon V4.03HE.

could someone help me with this issues? i thought about lens on dvd-burner
but i bought lens cleaner and cleaned multiple times…

The new disc’s that they bought are you sure that there is a write strategy in the burners firmware? Perhaps a firmware upgrade may solve that problem.
What error messages are you getting when it doesn’t burn as expected?
Download a free burning application and try that.
Have you installed a starforce protected game or have you played a drm protected cd? either can cause problems with burning.

i tried to burn verbatim dvd+r with roxio creator 8 instead of others.
(maxell DVD+R doesn’t get recognize at all)
it just says there was a problem writing to the disc. (it says 1% for a while and stopped)
i tried to find burners firmware and i couldnt find it. many people says there is lack of firmware for mashita. (i have acer laptop and there was no firmware for acer)
i am not sure whether i have played starforce game. if i did, how can i fix it?
(well i don’t think i played starforce protected game or drm protected cd, but i do use daemon for some games)

also when i sue nero cd-dvd speed to create disc, it would said error: power calibration area error.

Buy other 8x rated dvd media.