Please HELP! hard drive won't load

vbimport

#1

Could someone help me out here… … listed below is my origional question and a response… and my follow up response…

I can’t figure out what to do on this, I really need the info on this drive.

I can see the drive in disk management. I can also see the drive in device manager. (I have uninstalled and reinstalled the drive)

However, I cannot see the drive on my computer.

My WD hard drive won’t load anything

This thread is about the Western Digital My Book Essential Edition 250GB External Hard Drive. Click here to see full specs

Hi, I have had my (WD2500U017-005) hd for about 2 years now and I have a lot of data that I do not want to lose on this drive. I just got another WD 7500H1U-00 hard drive for Xmas. I wanted to put all of my info onto the new drive and store it in case anything were to happen, I would have a back up. However when I plugged the new drive up, my old drive won’t show up. The new drive is visible and I can access it. The old drive acts like it is loading up ( I see the blue light come on, and I can feel it running) I also hear my computer beep like it does when you plug in a new device and the little icon comes up to safely remove the drive, but it doesn’t show up in my computer. I even tried to unplug the new drive and plug in the old one, but that doesn’t work either. I tried putting the old drive on 2 different computers, but that doesn’t work either! Is there any way to open my files and get them off of the old drive?? Thank you for your help. Josh
Re: My WD hard drive won’t load anything

Welcome to the forums!

With our PC powered off, connect the drive, power it on, and then power up the PC. After the PC boots, go into Control Panel / Administrative Tools / Computer Management / Disk Management…is your drive listed there?


Google is your Friend
Re: My WD hard drive won’t load anything

Yes, my drive is there. How do I open the drive though? I know that it is loading up, but I cannot access the information on the drive. Nor can I see it in my computer…

It says disk 1
232.88 GB unallocated

how do I get my information off of the drive?


#2

No guarantee that this will work but you can try:

http://findandmount.com/

You may at least be able to copy your data off the drive.


#3

That absolutly worked perfectly!! I am transfering the data now. I guess when I put the new drive on it just stole the letter from the old drive instead of creating a new one. Thank you so much!


#4

You are welcome. Glad it worked for you.