Please help. DVD drive not reading anymore :(

vbimport

#1

after a lot of googling and going through some of the solution mentioned here i am still facing the problem and hence sharing with you all :slight_smile:

Few hours before i have formatted my Dell Inspiron 1545 suspecting virus activities despite having an anti-virus.

I was able to install a fresh copy of Windows Xp SP2. But after installation when i tried to install drivers using my DVD i was unable to do so as it never read it. Luckily i had a copy of driver in my usb to get my OS up and get it connected to internet.

Though my DVD drive shows in My Computer, but it fails to read any DVD/CD.

I have tsst corp dvd±rw ts-l633b in my inspiron. So what i did was updated the firmware but still the problem persists.

I checked my region settings and found that its showing region 1. Me being from India it should be region 5. isn’t it? when tried changing it, it gave following error. (see attachment)
i had administrative privilege but still gave error.

how to come over it?
what is the region setting by default?
5 chance remaining or 4 chance remaining?
as i remember i never touched the region settings so was wondering how it changed to region 1 or chances remaining 5 for the matter.

Please help me out here. i have lot of software to install from DVDs and don’t have usb DVD drive :frowning:

Even after changing the boot priority directing to my DVD drive it is not detecting hence i am not after to load windows 7 nor even able to give another try with windows xp installation:sad:

Please help :confused:


#2

is this the right section to post my query? :slight_smile:


#3

Yes, this area of the forums is fine for this inquiry.

Region settings only apply to commercially made movies. If you are installing software, the region setting should not apply.

This drive is a SATA interface laptop drive. Do you have all the latest motherboard drivers installed for the laptop? You need to download them from Del.

You can also try the link in my signature that says Microsoft support for optical drives. Follow their instructions on that page.

If that doesn’t help, you can also try removing the upper and lower filters, but on a new install, I don’t know that it would help: http://pcsupport.about.com/od/driverssupport/ht/upperfilters-lowerfilters.htm


#4

Yes, i have the latest drivers listed in dell site.
To run the tool it has some requirements. I do have sp3 but again not able to access my drive to install it.
And the upper filter and lower filter value is not there in registry. added attachs




#5

If the drive won’t boot up with the XP installation disk, you seem to have a dead drive, for unknown reasons.


#6

I guess its not dead, its acting weird…
Today i inserted my SP3 CD just to check if the drive is reading it or not. It actually gave auto run popup but detected it as blank cd :frowning:

next i tried with the redhat dvd and it detected it. but again…after that its not reading anymore dvd :confused:

my drive is dead? :sad: or is there something i can still try to get it working again?




#7

From your description of its behavior, I’d say it is time to replace it. Or get a usb optical drive instead.

The only other thing to try is to remove it from the laptop, disassemble it (take off the outer cover) and clean the lens with a soft cloth or cotton swab dipped in a small amount of alcohol.


#8

:sigh:
thanx for your help. ty :slight_smile:


#9

had problem with lens…hence some dvd/cd were read and some weren’t. that’s what the hardware engg told. so bought a new one. ty for the quick replies.