Playback problems

this is a home made dvd . The first time I copyed,

It would not play on my player done from nero .(it was a sony disc) source

And the second played on mine but with no audio.(memorex disc) done with clone dvd

the nero copy is exact copy with audio and video works on my comp not dvd player

the clone dvd copy works on my comp and dvd player with no audio

my links has screen shots of the source clone and nero copy along with a clone dvd screen shot that shows there is no audio

for some reason the clone dvd will no copy audio if i can get the clone dvd to copy the audio it would work

my dvd player takes ntsc video wich both copys are, and will not take dts audio

both copys and source has ntcs and only the clone copy will work on my player with no audio

the nero copy has ac3 audio and ntcs vid and wont read on my player will on my comp

Its a mvd 2015 dvd player from memorex…cnet has the best specs

Here are screen shots …
Every pic has a explanation underneath.

In my photo bucket pic 2 and 3

the one made with clone dvd wich will play on my player but with no audio says… in the container section…mpeg -2 stream video

and the nero copy wich wont read on my players says the same except it also says dvd vob format

Im thinking If I can get rid of the dob format it will work.

the clone dvd copy does not say that and my dvd player will read it but dvd clone will not burn audio…

if i can either get clone dvd to copy the ac3 audio file

or i can get the nero copy to be read on my dvd player it will work.