Pioneer DVR109 Firmware upgrade

vbimport

#1

I have purchased a Pioneer DVR 109 BK DVD writer.

I have downloaded the Latest Firmware 1.40 but cannot for the life of me get it to install, keeps saying drive not found. XP can see the drive OK, Nero can see the drive OK, have burnt with Nero OK.

I have made the 109 the master on the IDE channel

I have tried booting to DOS and installing the Firmware, still no good.

I think I should have shelled-out a bit more and bought a Plextor.

Has anyone got any ideas?


#2

You could still return it and see how many headaches you have then. :rolleyes: :bigsmile:
Good luck.


#3

Are you sure you are using the dvr-109 firmware not the dvr-a09 firmware… there is a difference…


#4

Yeah, double-checked Pioneer site have got the correct one DVR-109.


#5

The newest firmware is v1.09 which can be downloaded from here:

http://www.pioneerelectronics.com/pna/article/0,,2076_3143_202825678,00.html


#6

Thanks, but the drive is already on V1.17 and the latest is 1.40.


#7

It seems a lot of OEM versions do not accept the standard firmware - either that, or there are some severe interactions, though even a DOS flash fails.

A spot of DIY using DVDUpdate
http://flashman.rpc1.org/Firmware/PIONEER/DVR-109/

Often seems to be the only way - I’d advise hunting down a guide first.

One thing, if I’d been sold a “tied” OEM version (if that really is the case here), instead of an ordinary 109, then I’d be rather cross.

Or if their update just isn’t working properly on many machines, then they need to do something about fixing it.


#8

had similiar headaches.
resolved it by returning the 109 and getting the nec 3520a :slight_smile:
have been burnin’ like mad since…


#9

I had the same updating issue, I d/l the proper firmware 1.40 from the Pioneer site and tried to update it, nothing happened like the guide page explained it would, tried and failed a couple times. Best thing I did was format and instead of using FAT32 like I have in the past for my gaming addictions I used NTFS(switched after a friend convinced me about trying it). After doing all my MOBO updates n such, I tried the update one more time. It installed correctly and clean the first try.
Whatever it was that I did it worked and made me happy. Now try to stop me from burning muuhahahahahaaa. It’s fast and does what it is supposed to.
Happy Fragger once again !


#10

YAY!.. long live the 3520!!! :smiley:

(erm… okay… yes… the 3540 is already on the shelfs :p)


#11

had no problem with my 109 oem even updated firmware without any problems and it works great.


#12

bought this from newegg for 47.00 and I LOVE it i had a copy of a very popular movie still in theaters my buddy burned me and it wouldnt play on my player i got this and upgrade my firmware and installed quietburn patch with no hassle and it burns like crazy i love this drive and i would reccomend it to anyone considering buying one… :iagree: