Pioneer dvr107d only reads/writes cdr (no DVD support)

My dvr107d won’t read and write DVD-R and DVD-rom and DVD+R
I have tried to do a firmware update to v1.20 and the problem isn’t solved. I have also reinstalled windows and all my applikations.

I got the problem when I was using cdrwin 5.05 yesterday. I got a bad image file (about 1.7gb), and I thought I could burn it with cdrwin (nero couldn’t). My dvr107d burned the image, but the write speed seemed to be a little weird (varied from 1-56x), I burned the image in 2x and hoped it would work. After finishing it has only burned 1,5cm from the middle of the disc and the dics data was invalid.
Afterwards I checked the driveinfo in cdrwin and saw my dvr107d was able to write DVD-R and DVD+R at 24x speed (exactly the speed of the supported cdr writing).

Could it be that I have damaged something or how can I solve my problem?

I have updated to v1.20 as well and cannot get the burner to recognize and DVD media. At first I thought it was related to my Pinnacle software, so I installed the Ulead products that came with the burner, still no luck. Any ideas what I can check just to make it recognize the DVD media?