Pioneer DVR-K15

Hello everyone.

I have a Sony Vaio with a built in Pioneer DVR-K15.

Yesterday I could no longer access the optical drive. (Could be something to do with Windows or Sony automatic updates). Is anyone else having this problem?

Device manager shows the yellow warning triangle sign next to the Pioneer DVR-K15 entry.

I have tried uninstalling the device and letting Windows find it again but get installation errors.

I can’t find a driver anywhere to install manually. :sad:

I don’t think a firmware upgrade will make a difference and the threads on this forum say I can’t do it anyway on a Sony Vaio anyway.

Does anyone have any ideas?

Cheers.
Scott.

From the OS CD, there are the standard drivers foroptical drives.

Thanks chef.

Unfortunately windows isn’t recognising the drive so I can’t install from the CD. I was hoping download the driver from the internet.

Cheers,
Scott

Not even listed in Devicemanager?

Hi Scott!
Got the same problem :frowning: – did you found a solution?

Best regards
Christian

Connect to another computer via ethernet, serial or whatever, and transform the driver to yours.
Then instal the IDe driver again.

Hi Chef,
Thanks for the advice. I tried to copy drivers from another laptop using a USB memory stick. No joy. I can see the device in device manager but it has an explanation mark next to it. If I go into properties I see “Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)”. I have just seen that Roxio drag-to-disk is not working either and got a message saying it was missing a file on startup. Now trying to reinstall Roxio from a 1Gb microdrive via PCMCIA adaptor. no joy so far…I get so far and the installer asks for the Roxio Program disk which, of course, I can see. Aaargggh!
Scott.

Hi CVDNEXT,

Still no joy yet? I haven’t got very far myself.
Scott.

Why don’t you guys re-install your intel chipset drivers and see if that helps ?

installed all available updates from sony vaio update service inclusive “DVD version 2.4.10” and voila fun again with the K15 :smiley:

thank you all!
christian

Good news Christian,

I reinstalled click to dvd 2.4.10 but still have problems.

Reinstalled IDE drivers too - still can’t get the DVR-K15 optical drive to work.

Have run out of ideas and will try to contact Sony. I think it was their Vaio update which messed me up in the first place.

Scott. :sad:

Maybe you have other burning apps installed too?

Chef

thanks for all your help. I have resolved the problem and the drive is now working properly :iagree:

I went into the control panel:add and remove programs and found two versions of the click to dvd software. The new install had not removed the previous version properly. I removed the earlier version and viola…sorted!

Thanks for all the advice :bow:

Regards,
Scott.

Ui, that was a nasty zombie then. :wink:

8-E

I have the same problem. I have a sony notebook, which cannot detect the dvd-rom’s driver. I tried reinstalling the intel chipset but it didnt work. As i reinstalled windows, then i couldnt find a original copy of click to dvd. I dont have an OS cd. Please if someone could help me with this problem.
Latez,
Aqeel.J

What?!?

Sony indeed doesn’t ship an operating system on CD … the whole recovery system is backed up on a hidden 8GB partition that can be accessed through some Sony Vaio software crap … :Z

Hi

Have had the same problem myself after installing roxio media creator 7, after following the instructions and rebooting this fixed the problem:

  1. Start Registry Editor (Regedt32.exe).

  2. Locate the UpperFilters value under the following key in the registry:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E965-E325-11CE-BFC1-08002BE10318}

  3. On the Edit menu, click Delete, and then click OK.

  4. Locate the LowerFilters value under the same key in the registry:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E965-E325-11CE-BFC1-08002BE10318}

  5. On the Edit menu, click Delete, and then click OK.

  6. Quit Registry Editor.NOTE: After you remove the Upperfilters value and the Lowerfilters value, if you notice lost functionality in a particular program, such as CD recording software, you may need to reinstall that software. If the problem recurs, consult with the software vendor for assistance.

  7. Restart your computer.

HOPE THIS HELPS

Yep, similar advice in the HOW TO link in my sig. :wink:

hi
i have an hp ze2115 notebook and the dvd is pioneer dvr-k15
the dvd can read all the cds but cannot read any kind of dvd
hp sent me an e-mail, i did whatever they said, but no solution yet.
can somebody help me please?