Pioneer DVR-216D always thinks there's an audio CD in the drive

[qanda]This thread is about the Pioneer DVR-216D. Click here to see full specs[/qanda]Okay, this is a really weird problem, but I’m really desperate now and nobody seems to be able to help me. :frowning:

My old DVD writer popped a few days ago (a Lite-On) and the replacement I bought is a Pioneer DVR-216D. I’ve read they’re one of the best writers out there, and affordable too.

Well, at the minute I’m ready to throw it through the window.

Here’s the situation. It’s a SATA drive. I’ve got a SATA hard drive and now this SATA DVD-RW. Also I’ve got a DVD reader, connected as master via IDE. Installation went great, you can see it on the BIOS screen, Windows (Vista) starts and it sees the drive perfectly, except for one thing - it says there’s an “Audio CD” inserted. There’s nothing in the drive.

Thinking it could use a firmware update I download the latest firmware but when I try to flash the drive it says “eject the disc first”. GRRRRRR.

I’ve looked around and someone suggested running the firmware flasher in DOS. Which I did, but I get “this program cannot be run in DOS mode”. Reading around there’s issues with NVIDIA SATA controllers and optical drives but I don’t have them, I have a ULi SATA controller. Interestingly NVIDIA have bought them out though, and there’s been no update to the driver in over two years.

Here’s a screenshot of the important bits of my device manager screen…

With the drive, I can put a DVD-R in and it’s recognised immediately. I haven’t tried burning with it - I don’t want to waste a disc frankly - but it certainly reads discs and their properties okay. As soon as you take them out though - EVEN WITH THE DISC TRAY EJECTED - the status changes to “Audio CD”.

Dodgy drive or SATA problem? Any advice whatsoever?

Thank you to any kind soul who wants to help…

I decided to waste a disc and try a burn. I tried to burn an 8gb file with IMGBURN, which seemed successful, and seemed to verify. When inserting it back into the drive, it shows up as a 151mb DVD disc. When I eject it, up until the time I reboot, it shows a 151mb disc still in the drive.

I tried inserting it into a fully working drive and it also shows up as a 151mb DVD disc. How did IMGBURN verify it is what I want to know! Who said buy a Pioneer?!! :frowning:

Copy + paste what you see in the disc info box on the right when you’re in ImgBurn’s ‘Read’ mode.

Try it with and without a disc in the drive please. (When without, the box should actually be disabled so you can’t copy + paste).

[QUOTE=LIGHTNING UK!;2444986]Copy + paste what you see in the disc info box on the right when you’re in ImgBurn’s ‘Read’ mode.

Try it with and without a disc in the drive please. (When without, the box should actually be disabled so you can’t copy + paste).[/QUOTE]
I’ve actually got the drive unplugged at the moment (I’ll explain), but I looked for this myself.

It says for each category in the info box on the right “unknown”. I also noticed that when ejecting/inserting a disc into the drive, rather than saying “drive is not ready”/“drive is becoming ready” (or however it’s worded), like my other drive does, it says “no additional sense information”. Then suddenly it will recognise the disc and give me all the correct stats.

I took the drive out of the PC and plugged it into a friend’s PC, who has a more modern motherboard with a VIA SATA controller. I thought this would solve the problem and prove that it’s my SATA controller with the problem, but surprisingly, it was exactly the same. Well, almost.

Using my friend’s machine, Windows realises that there’s no disc in the drive, which is a step in the right direction. But the firmware updater still thinks that there is. I uninstalled all his CD programs (Daemon Tools and the STPI files etc.) out of pure frustration, desperate to get it to work, rebooted, and suddenly the firmware updater gives a different error to “please eject the disc”.

Yes, now it says “unknown error” - how $!%@ing helpful is that? :confused: So I tried the latest version of DVRFlash and guess the error DVRFlash gives… No prizes for guessing, it’s “please eject the disc”.

So now I’m totally confused. If it’s a hardware issue then why has the error message changed in the official flasher after taking Daemon Tools etc. off the PC?

No reply from the guy I purchased the drive off, looks like I may be stuck with it… He was selling 20+, I hope nobody else bought one and is having the same issues…

I’ve put the drive back into my computer for one last desperate attempt to get it to work.

Here’s the IMGBURN readout for you Lightning, without having a disc in…

PIONEER DVD-RW DVR-216D 1.08 (RAID)
Current Profile: None!

Disc Information:
Status: Unknown
Erasable: Unknown
Formatted: Unknown
Sessions: Unknown

It also says on the bottom left-hand corner:

Disc Is Empty

So I got a new drive from a different retailer and it does exactly the same thing. In two different PCs (with different motherboards / SATA controllers).

I’m all out of ideas…

I’ve just used Ultimate Boot CD (which lets you boot into Linux), and the drive appears fine. It also lets me browse discs and burn discs without a problem, so it would appear to be something in Vista that doesn’t like the drive.

I’ve uninstalled all traces of CD/DVD software that I had - Nero, Imgburn, even codecs in-case it was some kind of DVD video codec making everything go wrong - but I’m still getting the same problem.

I’ll be formatting tomorrow… (Yes I should probably just get a different make of drive but no, I’m determined to solve this!)

Are the SATA ports set to RAID or IDE mode?

Sometimes when set to RAID, causes issues with certain optical drives.

In the BIOS it’s set to non-RAID (doesn’t say IDE) - I disabled RAID as soon as I got the PC put together.

Yet in IMGBURN it says…

PIONEER DVD-RW DVR-216D 1.08 U[/U]

It’s definitely set to non-RAID in the BIOS though!

[QUOTE=Tranmere;2448808]In the BIOS it’s set to non-RAID (doesn’t say IDE) - I disabled RAID as soon as I got the PC put together.

Yet in IMGBURN it says…

It’s definitely set to non-RAID in the BIOS though![/QUOTE]

Same here when using Vista or Windows 7. Don’t know why.

Well, if nothing else, you can try booting some Linux LiveCD and flashing with DVRFlash.

The new drive I bought was already flashed to 1.09 which is handy, but it still has exactly the same problem.

I was going to format today as well but if it’s happening with both Vista and Windows 7 I suppose there’s not much point…

What the hell can I do now? Do I get an IDE version or will it have the same issues?

Other people use this drive with Vista succesfully don’t they?

I’m tearing my hair out here!!

I’d say to try the IDE version if you can. Something about the SATA controller / SATA drivers / Pioneer/NEC chipset SATA implementation isn’t working right for you.

After a NIGHTMARE of a job trying to format with Windows 7 (it just kept getting to 75% and freezing - eventually I left it on for 8 hours and it crashed, rebooted and seemed to be okay)…

The DVD writer seems to be recognised perfectly well now!

All that I did was update the BIOS to the latest version, switched to RAID and then switched back to AHCI again (without attempting to boot the hard drive), booted into Vista and it still had the same issues. So then I installed the last release of the Windows 7 beta, and hey presto, it is now recognised as a SCSI drive in IMGBURN (not as a RAID drive) and it doesn’t think there’s a disc in all the time.

I’ve restored all my old software now and there’s no issues whatsoever. Very weird problem though…

Is there any why to know the codec of an audio in a video file?

I SPOKE TOO SOON DIDN’T I?!

New problem. The drive (either, I have two now thinking that the initial one was broken) just stops writing to the disc at random points (Verbatims which I’m not happy about wasting).

It doesn’t come back on again and when I try to shut down the PC, I have to switch it off at the back.

The light on the front of the drive stops flashing and that’s it, it’s totally dead. I can’t even eject.

IMGBURN reports no errors, it just sits there for as long as I let it. Here’s a screenshot:

(Look at the write rate)

What the hell do I do now? I’ve had enough of this.

So it’s still a driver issue then.

Why don’t you buy a Silicon Image PCI card or something and shove the drive on that? The ULI one is obviously being a pain in the ar…

[QUOTE=LIGHTNING UK!;2451243]So it’s still a driver issue then.

Why don’t you buy a Silicon Image PCI card or something and shove the drive on that? The ULI one is obviously being a pain in the ar…[/QUOTE]
I’ll see if I can get one, thanks. Cheaper than a whole new drive.

Do you really think that will solve it though, bearing in mind it doesn’t like my ULi chipset and it doesn’t like the VIA chipset in the other machine I’ve tried it in? Seems like too much of a coincidence to me (although saying that I have no idea what the problem could possibly possibly be)…

Probably not a whole lot cheaper but then there’s nothing to say a new drive won’t have the exact same issue with your ULI / VIA controllers.

This is why I stick with Intel chipset motherboards… they work!

Wait, is this 64-bit OS?

I had “burning doesn’t finish” problem with Vista 64-bit, and everything worked fine in Vista 32-bit. I don’t think that’s a chipset issue.

You are joking…

Just when I’ve paid for a PCI SATA card as well, I don’t believe it…

What’s the problem with then in Vista 64-bit? An IMGBURN problem or a SATA problem or what? Please don’t tell me I’ve just thrown more money away on a drive that’s never going to work… I should have just got the IDE version from the start, would have saved me TWO WEEKS of this crap…