Pioneer DVR-107D

I have a Pioneer DVR-107D. I have tried burning DVDs (both DVD+R and DVD-R) using Roxio Easy Media Creator 7.5. But it always fails.

I tried updating my firmware to 1.21, but when I run the .exe file, I just get “Available target is not found”.

How do I run this firmware upgrade?

You didn’t mention what version firmware is in your 107 currently. Early versions of 107 firmware improperly left the hyphen out of the drive name showing it as “DVR 107D” rather than “DVR-107D.” This can cause problems with the default flasher.

Use DVRFlash to get around this problem. Follow the instructions in the included ReadMe file. As to Roxio Easy… Try out Nero Burn. You’ll be much happier.

I don’t even know how to check the firmware version. It has whatever it had when I bought this computer (Sony Vaio) a year and a half ago. How do I check the firmware version in Win XP?

Where do I get DVRFlash and the readme file?

Unfortunately, the server that hosts DVRFlash is in transition. It should be back in a few days… When that happens, you will be able to download it here. There may be other sources to download it (Try Google!). Any version since 1.3 should work fine on your drive.

To determine your current firmware version, just double-click DVRFlash. This doesn’t mean you don’t still need to read the ReadMe file since double-clicking will do no more than report your drive’s info.

Ok, I got DVRFlash

I have Revision : 1.00

But, when I try to upgrade it to 2.11, I get;
Commandline:
DVRFlash -vf E: R7100107.121

Reading firmware ‘R7100107.121’…
firmware is of Normal type (PIONEER DVD-RW DVR-107D 1.21 )

Drive Information:
Description : PIONEER DVD-RW DVR-107D
Firmware Rev : 1.00
Firmware Date : 03/12/25
Manufacturer : PIONEER
Drive is in normal mode.

Additional Drive Information:
Serial Number : CLDL013943WL
Interface type : ATA
DVR generation : 0007
Kernel type : SONY
Normal type : SONY
Kernel version : 0001

    Status : RPC-2 (region locked)
    Region : 1
   Changes : 4 region changes remaining
             4 vendor resets remaining
             state is 'Region set'

Firmware and Drive type mismatch
If you want to convert your drive, you need to supply both Kernel and General

Since it is reporting Kernel Type=Sony …do I need a Pioneer Kernel?

Where can I get a Pioneer Kernel for r 1.21

Yes. You can find a kernel here. Thanks to Flashman.

Thanks!

That worked. Now I am on 1.21.

But EZ Media Creator STILL won’t burn DVDs.

I can make DVD Data disks but not DVDs (Video).