Pioneer DVR-107D Model Firmware Update not working

Hi, I have a Pioneer DVR-107D DVD burner, but I cannot update the firmware.

Is the latest version supposed to be 1.22? The us pioneer firmware update website shows DVR-A07/107 I’m guessing it’s this one: DVR107D_FW122.exe (version 1.22?); whereas pioneeraus.com.au’s firmware page, the same model (DVR-107D DVD Writer) firmware is 1.21. I tried running both exes and both end up as “Target not found”. I have the drive connected to Secondary IDE by itself and set to Master. I’m on Windows XP SP1. Can anyone help?

Have you tried using DVRFlash to flash the drive? If it fails, could you post the result of the command:

 > dvrflash -v X:

…where ‘X:’ is the physical address of the drive.

Your drive obviously has an patched fw applied.

The offical firmware packages will NEVER allow you to update from hacked/patched firmware!

Try DVRFlash as it’s master himself LasVegas suggested you.

My drive has a patched firmware? I’ve bought it retail and I’ve never flashed the drive before.

Sorry about the cross-posting. (I later decided it was better to just create my own topic)

Anyway, I haven’t tried the DVRFlash tool. It sounds promising, though. :smiley: But I’m not exactly sure where to start… I’m not really familiar with command prompts. (dos type things scare me… :eek: )

I copied the R7100107.122 file to the same directory as DVRFlash.exe. Now, do I just type “DVRFlash -vf D: R7100107.122” on the command prompt?

Ok, I didn’t know I had to use “cd” command to go to the directory with dvrflash first. (I don’t use dos!)

Ok, it asked to supply both “Kernel and General” what is what? The firmware I downloaded from the pioneer site had a file called R7100107.122 and UPGR107.exe. Is that the kernal and general?

In command prompt, I typed “DVRFlash -vf D: R7100107.122”

Before trying to flash, enter the command

 > dvrflash -v X:

… where X: is the drive letter of your drive. If the Firmware and Kernel names are other than “GENERAL,” you need to get the updater for your OEM drive or download the complete Firmware/Kernel package from another site such as >NIL:'s PioneerDVD RPC1 site.

If the types are in fact GENERAL, use the command

 > dvrflash X: R7100107.122

…to flash your drive.

Okay it said…
DVR generation: 0007
kernel type: PIO_ADV
Normal type: PIO_ADV
Firmware Rev: 1.18
kernel version: 0002

So I guess it’s not general? What should I do now? I don’t understand why Pioneer even bothered to release an update program if doesn’t even update out of the box.

I found this site; I see there are some dvrflash kernel zip files, but I don’t know if is trustworthy - and there is none for 1.22 (latest)

You need to flash your drive with the DVR-107XL firmware. This is the variant that works with the Quietdrive technology.

The kernel does not necessarily update with each firmware update. If the firmware was not updated since the previous update, Pioneer won’t release the update with a kernel. Just update with just the firmware as described above.

Hmm, I thought DVR-107XL firmware was for a completely different model - but it worked!! =) Thanks.

YAY, no more stupid Power Caliberation errors! And it seems a lot quieter too.

You cannot blame Pioneer for downloading the wrong firmware update for your drive, simply that is. :wink:

Haha… but, but… when I checked my Hardware->Device Manager, it’s listed as PIONEER DVD-RW DVR-107D. :\ I don’t understand how an average person would know just from “PIO_ADV”. Maybe the retail box said XL? lol hmm, I bought it years ago so I don’t know where the box went. Still, it should say DVR-107XL on the device manager! Oh well, no more coasters =)

I can’t believe this burner cost hundred dollars; burners are getting so cheap now! I just ordered a NEC burner, which is like 1/3 the price, and faster and DVD DL! =)

Wrong conclusion. All 107 drives are listed as 107D, but only the real XL drives come with the very different looking Honeycomb design case…

My first dvd burner had cost more than $350, you cannot compare prices and drives from today with those in the past!