Pioneer DVD + RW DR-K17Y

vbimport

#1

Hey, just signed up here not too long ago. I’ve been trying to find drivers for my Pioneer DVD + RW DR-K17Y burner but I’ve had no luck. If someone can send me a link to download them that would be wonderful. Also, I’ve tried the Dell website but had no luck on there.

Thanks!


#2

Welcome to the site wtc-tucker.

This is apparently (?) a dvd drive in a Dell laptop. The reason you cannot find drivers for this optical drive is because the necessary drivers are included with the operating system and don’t need to be updated.

Perhaps you mean firmware instead? Tell us the model number on your laptop and we will probably be able to tell you if there is a firmware update available from Dell.


#3

My laptop is a Dell Inspiron 6400. The model number on the bottom of the computer is PP20D.


#4

deleted


#5

The latest firmware is the A03 version from 9/14/2007. http://support.dell.com/support/downloads/download.aspx?c=us&l=en&s=gen&releaseid=R166917&SystemID=INSPIRONI6400/E1505&servicetag=&os=WW1&osl=en&deviceid=12939&devlib=0&typecnt=0&vercnt=1&catid=-1&impid=-1&formatcnt=0&libid=32&typeid=-1&dateid=-1&formatid=-1&source=-1&fileid=225595

You can check the current firmware version by installing ImgBurn. It is a free burning program that is quite capable. Click on Discovery once you have the program installed. At the top right in the main window of ImgBurn, you’ll see the name of the drive and at the very end, it will show current firmware revision, which should be similar in nomenclature to the A03 that is available for download from Dell.

If you want to install this new firmware, you’ll need to unzip the download, then hit the executable. Don’t interrupt the flashing process.


#6

Man your are fast Kerry :slight_smile: also for hacked F/W you can check here if you want http://club.myce.com/f87/mediacodespeededit-support-pioneer-dvd-writers-153213/


#7

When I clicked the link to download the file, it gave me the Dell Driver Download Manager application and when it searched for it drives it said “There are no files to download. Please go to drivers and downloads to select files”.


#8

That’s very weird. When I click on the link it takes me directly to the exact firmware download.

If you have another browser installed, you might try it. I use Firefox full time. Chrome is also good compared to IE.


#9

Yeah I’m using Firefox right now, I can’t stand IE. I can’t figure out why it won’t take me to the firmware, any other ideas?


#10

http://www.mediafire.com/file/mn2dgm2zzen/R166917.ZIP

I downloaded the zipped firmware from Dell and uploaded it to a free hosting service. You should be able to download it from this link. If this firmware is not newer than the one in the drive now, it may not install.


#11

Okay, I was able to downloadt hat zip file no problem but when I go to install it it says Available target is not found.


#12

That was my best shot I’m afraid. If the flasher cannot find the drive, this firmware won’t work. Best to talk directly to Dell at this point.


#13

[QUOTE=wtc-tucker;2526401]Okay, I was able to downloadt hat zip file no problem but when I go to install it it says Available target is not found.[/QUOTE]

Did you unzip the file and save it first or are you trying open it from within the zip file?

[B]Wombler[/B]


#14

I unzipped it to my desktop then tried to run the executable file and it said the target wasn’t found