Pioneer 212BK problem

Hi! I just bought a new computer and I have a problem with pioner 212bk sata burner. It can’t read 90% discs that I inserted into it, but when I tried it on other computer it works perfectly. New computer has msi mb with nforce 520 chipset. I tried nec 4550 on it and it works perfectly. I tried changing sata cables but it didn’t help. What should I do?

NEC 4550 is an IDE/PATA drive, the Pioneer 212x is SATA.
All depends on the SATA controller & its settings on your mobo.
Which one is it?

Try to find it out by using devicemanager and post the info here.

Ok, Nec is ata and it works on both computers. Pioneer is sata and it works only on my old computer. It’s connectede via sata port properly. I can see it in bios and I can see it in windows but when I insert disc into it then the problem begins. I will post picture from device manager as soon as I get home.

Here is the picture from device manager. Please tell me if you need something else.


Please expand any tree under “storage contrllers” and post again a shot.

Ok, here it is…


Ugh, where is the sata controller hiding?

Under ide ata atapi controllers or disc drives? :confused:

Here is another one.


Nforce chipset… First thing is make your port is configured as Legacy/IDE instead of AHCI or RAID, if that doesn’t help it seems uninstalling the Nvidia ForceWare drivers seems to have worked for a lot of people.

Where do i configure port as Legacy/IDE?

Usually in the motherboard BIOS settings regarding SATA/IDE.

Ok. I don’t have nvidia graphic card so I don’t have forceware installed. I installed some motherboard drivers from cd that came with mb but I don’t have option to uninstall them. In BIOS, under Integrated Peripherals there is On-Chip ATA Devices submenu and there I have raid option which is set to IDE and I can change it to Raid or AHCI. I tried setting it to AHCI but then Windows wont boot. What should I do?

Does anybody know what should I do?

I suggest to buy an extra sata controller card (PCI) with ITE or SI chipset.

@ forum_girish
I don’t understand what are you talking about, anything related to Pioneer DVR-212BK? No? Start your own new thread. Also, do you think you are on the right forum for asking your question? :confused: It’s more likely you should go to a programming forum

@ Hollywood
have you tried to plug the drive to other SATA connector on your motherboard?

I have tried that and it didn’t help. If there is nothing else to try I will return it to the store where I bought it to replace it.