Pioneer 111D Stuck in PIO Mode

vbimport

#1

Hey Folks,

I am hoping someone can help me fix my problem with my Pioneer 111D DVD-RW drive. There is a bit of history here, so bear with me. I built a brand new machine with an ECS KA3 MVP Motherboard, and an AMD Athlon X2 4200+ CPU. I swapped hard drive from an old machine, and did a repair install of XP pro and everything went fine. I have a 120 gig HD and a 300 gig HD as master/slave on the primary IDE bus, and Pioneer DVR-111D as master on the secondary IDE bus. However, after about a week my DVD drive started fail when I tried burn any discs.

I did some Google searching and discovered people had similar problems with this JMicron JMB363 chipset that is used as the secondary IDE bus on my motherboard. I did install JMicron drivers from the CD that came with my motherboard when I first set it up. In an attempt fix the problem, I downloaded a new version of the drivers from the JMB website for the chipset. When I ran the installer, it gave me two choices, to either install in RAID mode or install in IDE mode. Neither one worked. If I installed in RAID mode, my DVD drive was recognized as an SCSI drive and it would fail with IO errors every time I tried burning discs. If I installed in IDE mode, it worked but was stuck in PIO mode, which meant horribly slow and error prone burning plus it pegs the CPU. I could not, no matter what I tried, get the drive to be in DMA mode.

So I tried hooking both of my hard disk drives up to the JMB seconday IDE bus and the DVD drive to the primary. Big mistake. When I booted back to Windows it gave me an error saying my Windows profile was corrupt. It tried to install some driver then rebooted. When it did, Windows would not boot. It kept cycling back to the bios. Somehow the JMB chipset erased my windows partition. I lost everything on my main drive. I had to reformat and re-install Windows. However, once I got everything back up, I DID NOT install a driver for the JMicron chipset. Windows installed its own PCI-IDE driver. It worked great for a week or so, my drive was in DMA mode and it was working.

However, last night I was burning a disc and all the PIO symptoms came back. I checked the device manager, and low and behold the secondary IDE bus was in PIO mode only. Grrrr its so frustrating.

I have tried everything to fix this. In the device manager, there is an option to set it do ‘DMA if available’ but it doesn’t get it out of PIO mode. I have tried various different apps/scripts that ‘hack’ the registry to get it go into DMA mode, none have worked. I have tried uninstalling the entire IDE channel in the Device Manager and letting Windows re-install the drivers. Still it is in PIO mode.

I am completely at a loss now. I don’t want to install any JMicron drivers, I am NOT going to try and hook up my Hard driver to the secondary IDE bus again. Does anyone have any suggestions on how to get the DVD drive back into DMA mode?

Thanks in advance…


#2

You need to use the newer 80 conductor ribbon cables for the DVD drives as well as the hard drives. These are also called ATA 100/133 cables.

I’m sure glad I have almost all SATA devices in my computers now.

Beware of RAID. It’s more lethal than the avian flu.


#3

Take a look at this thread
http://club.cdfreaks.com/showthread.php?t=189057


#4

Thank you both for your replies.

Steve b: I am using the IDE ribbon that came with the ECS board. Would it not be one the 80 pins ones? How can I tell if the one I am using is correct?

loimlo: I actually have read through that entire thread and tried everything to no avail. If fact, I myself made a post on it near the bottom of the second page. :-/

The IDE ribbon thing sounds hopeful. I am this close to just buying an external enclosure so I can burn DVDs/CDs again…

I know it is not the DVD drive; I unhooked one of my HDD drives from the primary IDE slot and plugged in the Pionner DVD drive, and when Windows booted I verified that DMA was enabled on the drive. After what happened before I am leery about hooking up any hard disks to the JMicron bus for fear they might be erased or corrupted like what happened to me before, so I am stuck with PIO mode untill I can figure this out. Another odd thing, I took an old old crappy 9 gig drive I had laying around and hooked as the Master (and the DVD drive as the slave, as the post loimlo pointed out suggests) and BOTH drives were actually shown in PIO mode when windows booted!!! The Jmicron chipset is just fscked, or it might be the cable.

Thanks for any help that can be offered.


#5

THIS WAS IT!!! Thank you so much for your suggestion. :clap: It all makes sense now. I found an IDE cable from a hard drive I bought that I never used. When I compared it to the one in my PC hooked to the Pioneer drive, that one was much thinner, with less wires (about half). Then I realized that the cable I was using was labeled “CD-ROM cable”! It dawned on me that the other cable I was using to hook up my two HDDs was the “hard drive” cable and was the 80-pin type. This is why it worked when I hooked it up to that cable. It seems Motherboard manufactures use the 40-pin cables as the CD-ROM cables. Everything is working correctly now, thank goodness. I have spend hours and hours trying so many different things and it was )*#%# cable the whole time.

Thanks again, I owe you a beer!!!