Pioneer 110D keeps ejecting empty Tray

I tried this question in the Hardware forum but no one answered so I am going to ask here.

I just purchased a 9 bay Wytron Duplicator tower with 9 pioneer 110D 16x dual layer burners. I have done approx 10 full tower burns without problems. My last burn it stalled out about 1gig short. I pushed the button for abort and nothing happened. Finally I tried ejecting the top tray and it ejected and the rest of the burn took place without any more problems. All the rest of the 8 burnt good copies.
So now the bottom tray ( please note, not the one I ejected manually during the burn ) will not stay closed. It keeps ejecting a empty tray.
thanks in advance.

Did you flash latest firmware? I think I remember something being mentioned in the 1.17 changelog about a weird but like this but it was for Windows ME. Flash the Dangerous Brothers 1.22 if you havent already.

The drive is so new the Wytron duplicator may not be 100% compatible with it. I know there was some issues with this tower and the 109 as well.

I will try and let you know how it goes.