Pioneer 108DVR burning errors

My config:
-Abit NF7-S Rev 2.0 motherboard
-AMD Barton 2500+ @ 2500
-Seagate Baracuda 120GB SATA 8mb cache HDD - SATA0 - system partitions
-Maxtor 120GB 2mb cache UDMA6 HDD - IDE1 master
-LiteOn 52327S 52x32x52 UDMA2 CD recorder - IDE0 slave
-Pioneer 108DVR Firmware 1.06 UDMA4 DVD recorder - IDE0 master
-Triple boot: Win98SE, WinXP SP1, Mandrake 10.0

Problem:
I bought Pioneer 108 the other day. When i try to burn quality DVD or CD media I always get several burning errors. When i compare original and burned data (CDCheck) 1 to 10 bytes dont match - infact only 1 (one) bit per corrupted byte is bad. I never get CRC reading errors - so i think the data is corrupted before/during data translation to the burner - burned burned it that way inserting right CRC codes. .avi .mp(e)g .mp3 files are not sensitive to those kind of errors, but .exe .zip .iso are. .zip archive will not unpack, for instance. Tried to burn with several software products under Win98se and WinXP. I always got the same results. Went to friends, and tried burner on his machine. Surprise! It works fine - 0 errors.
I think the problem is hardware/driver related. I used to have problems with Lite On CD recorder which I solved by upgrading motherboard`s BIOS to version 26.

Questions:
1.What can i do to solve the problem?
2.What will i gain if i upgrade firmware from version 1.06 to version 1.14. I`m not sure if firmware upgrade voids warranty.

Thanks in advance.

Check to be sure you are using the MS drivers for your IDE that the burner is on and not the NForce IDE drivers.

Tom

Thanks for the reply.
In device manager under IDE ATA/ATAPI controllers i had:
-NVIDIA NForce MCP2 IDE Controller
-Primary IDE channel
-Secondary IDE channel
I just rolled it back to previous installed version. Now i have:
-Standard Dual Channel PCI IDE controller
Got to restat machine.

Question:
-What are the side effects?

Thanks again.

No luck. It works even worse with M$s standard driver.

Have you tried using a different IDE cable? You may have a dodgy one.

I use standard ATA-100 cable. LiteOn is on the same IDE cable, yet works perfect.
I tried out several things with and without NVIDIA drivers:
-Disabled DMA - transfer mode was PIO4 - i got no burning errors when burning CD-s and 1 bit errors per DVD when burning DVD-s
-Used old ATA-2 (33MHz) cable to make burner to use lower transfer mode - transfer mode was UDMA2 - same results
Im starting to lose patience. Ill try out burner on 2 other machines tomorrow (at work).
If it still wont work, ill try to return it to the suplier. They better accept it back, or i`ll have to break some bones.

Is firmare upgrade (1.06 -> 1.14) worth effort?

Thanks.

If you upgrade your drive’s firmware with an official one (Pioneer-released) you will not void the warranty (I have done it today). CD-RW burning works fine; although I have not tested DVD burning because I have not bought any DVD-R yet.

Well, as I am almost a newbie to DVD burning there’s what I know about errors:

  • Try reducing writing speed (I know it works very few with problems like this);

  • What media are you using ? Using bad media is, as far as I know, the most common error when getting coasters. If you use Princo DVDs try better ones like Verbatims and TDKs :wink:

Why would you ever dissable DMA? Your DVR-108 is ment to run in ultra dma 4 ultra 66. Its on Pioneers site. I would put the new 2.6 n_force IDE driver on. The 108 likes to be the master as well so if its slave to your lite-on switch them around and remember to change the jumpers on the backs of the drives.
Media is a big deal. You get what you pay for and cheap media meens cheap burns/quality. The good ones are Verbatum , Ritek/Ridata, Arita, TDK are Riteks, Taoyuden($$$) Bad ones Memorex(IS IT LIVE OR IS IT GARBAGE) no name silver spindles(make good coasters) -Princo change from batch to batch and optodisc are also not great. From what I have found quality discs have darker dye. All the ones I have had problems with were light ble to green dye. All failed or faded with time. You might be able to watch it once, but throw it in 1 month latter and the thing is missing data. Thats my 2 cents. :wink:

Thanks for your replies. I use Verbatim and TDK only.
I disabled DMA to see if it will work with PIO4 transfer mode. No luck.
Ill put new nforce2 IDE driver, thanks. I was just about to do that. This problem is not media related - for instance, i tried to burn 10X TDK CD-RW and i still got errors - whilst i dont get burning errors with the same CDRW on LiteOn or any other machine.
Tried to disconnect LiteOn, without success.
I`ve found on other forum that disabling “Auto insert notification” can help.

Try updating your drive to the official 110 and see if you get any improvements. I heard there were minor problems with 106. You say you just got your drive and it came with 1.06? I got mine last wed and it came with 110! They are doing some different stuff with the 114 firmware like compressing +R write stratagies and I have heard people having problems with +r media since so try 110, it works great. :eek:

Why?, you have previously stated it works fine in another machine in your first post. If this is the case there is nothing wrong with the drive at all and the supplier will be under no obligation to take it back.

I would try upgrading the firmware to 1.14 and try the drive as a master on the IDE channel by itself and see how it goes.

I would also check to see if you have the latest BIOS for your mobo, and once again try the latest MS IDE drivers instead of the Nforce ones, as anecdotely the Nforce drivers have had probs with burners before.

PS I just noted that you triple boot, have you confirmed the problem exists with all three OS’s on your computer?

I’m sorry to hear of your troubles, but that’s about all I can suggest.

ACK … don’t upgrade your firmware at this time.

Before you do ANYTHING, run memtest86 on your system for several hours.

First of all, its not the drive because it works fine in another system.

Secondly, its not the cable, because in DMA mode, all transferers are checksummed and checked on both ends.

This only leaves the computer, which means the motherboard/cpu/memory configuration could be flipping bits. If you upgrade the firmware on such a system, the firmware may become corrupted before it is transferred to the drive. Hopefully the drive will check the firmware itself to make sure that it is a valid and uncorrupt copy before writing it to flash, but its still very risky.

BTW, don’t use the nforce IDE drivers.

@Reality: Gladly, but i cannot find version 1.10 on Pioneers website. I would be grateful if some1 can paste me download link. @Geoffman:Just wanted to double check. Same result - it worked fine with Verbatim 2.4X RW media on VIA KT400 based motherboards. Guess i wont have to break any bones after all. :slight_smile: I do have the latest BIOS (version 26), i flashed my motherboard the other day. I confrimed the problem with Win98SE (uses M$ IDE drivers - there are no NVIDIA IDE drivers for Win98se) and WinXP SP1 (tried: WixXP SP1 Standard Dual Channel PCI IDE controller, NVIDIA NForce MCP2 IDE Controller and NVIDIA nForce2 ATA Controller v2.5.; with transfer modes PIO4, UDMA2 and UDM4; in pair with other device on same IDE line, and alone; as master and as slave). Didnt try to burn DVDs under Mandrake. - The best result - one bad bit per DVD - the worst result - ten bad bits per DVD. @rugger: My machine is very stable. I used to test it before with memtest86. I dont have any other problems with my machine at the moment. Perhaps there is slight chance that firmware can be corrupted, but i`ll bite a bullet.

Thank you all for your suggestions.

First success: After upgrading firmware to version 1.14 managed to burn first error free DVD on my machine under Win98se. Media was Verbatim RW DVD 2.4X. Forgot to allow DMA, so burning process lasted for 45 mins!

Clueless what to do next. Same symptoms as before when using DMA.

You need to set DMA on and leave it alone! Your problem is not DMA. Not having DMA enabled is just wrong. Are you using the newest versions of burning software? Go to the firmware page (search in google) and post your problem(in as much detail as you can)on the Forums.

After 5 days of hard work I think I finally managed to solve the problem.
What did I do?
I logged to Win98SE, and in System -> Device Manager -> Pioneers Settings tab: -unchecked: Disconnect -checked: Sync data transfer -unchecked: Auto insert notification (this one did the trick, I think). -checked: DMA To be true, appart last one, I dont have a clue what these options do. I read on some other forum that some guys solved NVIDIA nForce2 vs CD burner problems by unchecking “Auto insert notification”.
After I rebooted Win98SE, i managed to burn error free Verbatim DVD RW 2.4X with UDMA4 transfer mode.
I`ll look up explanations of aforementioned options and post them here eventually.

Things to do:
-All works fine in Win98se, but I want to be able to burn DVDs when logged to WinXP too. Unfortunatelly, aforementioned options are not so easily accessible via WinXP GUI. If I want to disable “Auto insert notification” I have to use some utility. I will look for one; meanwhile, if some1 can recommend one, that would be nice.

Thank you all for your suggestions. I hope that this thread will save some time to next guy with simillar problem.

At the end, Im sorry for all syntax and semantic errors - since English is not my 1st language, I did my best, but i didnt bother to use spell checker or some other utility.

Greetings to Rossz!

Apparently, “Auto Insert Notification” (AIN) is the service that notifies system that a new CD/DVD is in the drive; OS is notified that new CD/DVD is in the drive and launches appropriate application.
Disabling this option procudes side-effect (that I can live with) : new CD/DVD will not be launched automatically.
Here you can find how to disable AIN in WinXP: http://help.acoustica.com/mp3-cd-burner/2kain.htm

Disabling AIN had no effect under WinXP. Have to solve additional issues.

Your CPU is probably overclocked too much.
Try running prime95 torture test, to test system stability.