Pioneer 105 stopped reading dual layer discs

vbimport

#1

Like the title says, my Pioneer 105 just suddenly stopped reading dual layer discs. These aren’t burned discs or anything, just regular old store bought DVD movies or DVD-ROMs.

Single layer DVD will work (store bought ones plus -R and -RW burned discs all worked), CD will work, it’s just dual layer DVD that it’s balking at. Stick in a dual layer DVD, and it just hangs for a bit with the drive light lit up then finally gives up. Multiple known good DVD’s have been tried and don’t work.

I was running firmware 1.00, but upgraded to 1.33 in hopes it just might fix things. Firmware upgrade went smoothly, but didn’t fix the problem. Still runs DVD single layer and CD just fine, won’t recognize dual layer DVD. Oh well, it was a long shot.

I’ve got a 98/XP dual boot, and it’s the same situation on either OS, leading me suspect it’s a hardware failure, not something funky with the software or drivers or anything.

Is there anything I can do short of getting a new drive? :sad:


#2

Try cleaning the drive, otherwise get a new drive.