PIO to UDMA mode

vbimport

#1

Hi there, can anyone give me some advice about my BIOS settings.

Currently when my pc boots up and I go into the BIOS settings my pc displays the cdrom attached in PIO mode and not UDMA. I'm using the Elite Groups ECS K7S5A motherboard without lan.

I've flashed my BIOS previously so it can support better cpu's AMD K7. I'm currently using Athlon 1.8ghz with 512 DDR RAM.

Thanks in advance, hope it's not stupid question!!

chrome ;0)


#2

just change the setting in your bios and in windows.

normaly windows and your bios detect the right settings

it can be possible that PIo is the drives fastes routine to communicate


#3

Hi Damian, in the BIOS setup the drives can only be set in PIO mode 4 or 5, but no reference to UDMA. On detection my HDD states it is in Ultra DMA 5, it’s a Seagate Barracuda 7,200 rpm.

All the drives within Control Panel, System etc are set to DMA.

Is that okay??

chrome


#4

is there an …auto…option??

i guess your setting are ok


#5

What does it say in Windows? PIO or UDMA?!

Maybe this thread can help you some more when your operating under windows.


#6

Hi m8 - Loads of problems with windows XP relating to changing DMA settings from PIO to UltraDma. If you are using XP then u need the following registry hack to force the OS to reconsider the settings - DONT FORGET SYSTEM RESTORE FIRST!!!

Open RegEdit

Find the following KEY

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

The last four digits will be 0000, 0001, 0002, 0003, and so on.

Under each key, delete all occurences of the following values:

MasterIdDataChecksum

SlaveIdDataChecksum.

Reboot the computer. Windows will now redetect DMA settings, and hopefully enable them.

Hope this helps

Steve


#7

Hi,

Got any registry hacks for Win98SE - no matter what, my secondary IDE bus is in PIO mode and my Plextor 241040a is not running at its best - bios, etc, all checked and the DMA tab is not listed - it was at first, but Win98 changed it’s mind at it is gone forever.

I have deleted the cd writer and dma form the system, got both reinstalled, still the same. 80 pin cable, etc, driving me mad.

Ice’y


#8

98SE takes me back to those bad old days of blue screens of death and continual reinstalls - Move on my friend - dont listen to the doubters - use XP and be happy (nearly happy anyway!!)

As far as I can remember - there should definately be a DMA tab in the device manager for IDE ATA/ATAPI Devices on both primary and secondary displays. If not then you have replaced the drivers with older or incorrect versions. Goto the website for your motherboard or mobo chipset and get the latest drivers for win 98se and reinstall em all. Reboot and the tabs should reappear.

I do recall having some difficulty with keeping the DMA settings after checking the box - I think you may have to check them one at a time and reboot immediately after doing each one - you shouldnt have to - but there u go!!!

Good luck

Steve