PIO-modus with Plex?

I’m posting this for the 2nd time now, cause in the dutch area nowone had a solution.

This is the prob.
My Plex2410 is connected to IDE1 as a master and my Toshiba SD-M1502 is on IDE2 as a master, while my HD’s are connected to the ATA100 controllers.

While I burn a CD the whole the orange light goes to green, so about 2s of burning (orange) and then 1s stopping (green). So burning a CD takes ages this way. (full cd @ 24x takes about 9min) But the strange thing is, that my buffer is always full!
So I immediatly thought about my DMA’s offcourse. So I checked them out and saw that for the Plex was “PIO-modus” selected! However, “DMA, if available”, is selected. Now I’m sure I had my Plex running in DMA before, so I find it strange that is suddenly has changed to another mode. :confused:
So, I removed the device from the sys and rebooted without the Plex attached and saw that the “autom. selection” was again visible. So I rebooted again with the Plex attached again, but once again, it’s in PIO-modus. :mad:
I also tried installing newer Via busdriver but they had no effect.

I’m very curious what the solution will be this time.
I’m running WindowsXP (NL) btw on a Asus A7V133.

Edit:

My software buffer stays full all the time (CCD/Nero), but my recorder buffer goes up and down the whole time.

Sorry Wook I can’t help you… I have the exact same settings…

OS: WindowsXP Pro English

IDE1/MASTER (Harddisk) runs in DMA mode 4
IDE1/SLAVE (DVD) runs in DMA mode 2
IDE2/MASTER (Plextor) runs in PIO

IDE1 uses a UDMA100 flatcable (80 pins) and IDE2 uses a standaard UDMA33 one (40 pins).

I have the same problem when I want to write @ 12x while my USB modem is connected. When I remove this device and reboot I can burn without problems. I posted this before too and got no (working) reply :frowning:

I’ll keep my eye open for a sollution…

For some reason Win XP once in a while down grades form Ultra DMA 33 to PIO 4. Download VIA miniport driver at viaarena.com. And Force it to use Ultra DMA 33. I had the same problem and before what I had to do is uninstall the cdrom for windows device manager and reinstall it telling it its Ultra 33.

The reason that it takes 9 min is that PIO 4 is not enough in this case to supply a enough data to the writer and it keeps filling and then depleting the buffer. Its more like burning at about 10-12x.

Thanks for the tip Master_Ice… I will try it tonight (at work now :() and see how it goes. I’ll report back here with my results.

Originally posted by Master_Ice
The reason that it takes 9 min is that PIO 4 is not enough in this case to supply a enough data to the writer and it keeps filling and then depleting the buffer. Its more like burning at about 10-12x.

Yes, I already had found out that PIO just couldn’t handle the data transfer.
Will now go and DL that miniport driver you’re talking about and will get back to you.

Thx so far. :slight_smile:

Thx dude! It works! :smiley:
It does make some changes to the sys, cause I can no longer readout my IDE status the normal way; through the device manager. Now I can only look it up in the Miniport tool. But who cares? As long as it workes! :wink:

Thanks again! I can now write again @ 24x without probs! :stuck_out_tongue:

Cool! I’ll give at go later tonight and see what happens. Thnx for the file btw Wook :wink:

Originally posted by G@M3FR3@K
Thnx for the file btw Wook :wink:

I just gave you the file, the thx goto Master_Ice! :wink:

Tested it today with this little tool and it worked like a charm! Burned an mp3 disc with CDRWin @ 12x while connected to the internet… The buffer stayed full the whole time and the drive burned the disc withoud any hickups. Great :smiley: Thanks again Master_Ice!

Hmm… don’t know if this miniport driver is the one who did this, but I can’t burn with CCD anymore. It says "filling buffers’’ and then ‘‘flushing buffers’’. Then I get a error that the start of burning with my Plex didn’t work out ok.
When I use Nero there’s no prob! So I reinstalled CCD but no luck, still the same thing.

:confused:

I had this same problem with my Plextor.
I dont know why but for some reason DMA would only become available [In WinXP] if I had the drives set to ‘Auto Detect’ in BIOS, this works fine except when the drive sometimes does not get detected [Auto Detecting Secondary Master…NONE!].
In this case…the drive still functioned under XP but was running in PIO Mode :]

This may be of some help…but who knows…

I have don’t normally use clonecd so I didn’t know about the problem. So to see if I had the same problem I installed it and tried it. And guess what I had the same problem that you did. However :smiley: :smiley: if you ElbyCDIO Driver Control Utility and set it to WINASPI32 (safemode) it should work. It did for me. I tested it at 16x because of the media I have and I had no problems. Hope this works for you aswell.

Originally posted by Master_Ice
I have don’t normally use clonecd so I didn’t know about the problem. So to see if I had the same problem I installed it and tried it. And guess what I had the same problem that you did. However :smiley: :smiley: if you ElbyCDIO Driver Control Utility and set it to WINASPI32 (safemode) it should work. It did for me. I tested it at 16x because of the media I have and I had no problems. Hope this works for you aswell.

I also tried that, setting it to WINASPI32. But still the same thing!
Gonna experiment more after a night of rest. :slight_smile:

Originally posted by Master_Ice
WINASPI32 (safemode)
Isn’t recommended for CloneCD :frowning:

Originally posted by Olli
[B]The CloneCD “SafeMode” is the last hope - and a major kludge.
In this mode CloneCD can’t “lock” the drives exclusively. This is very bad if you try to copy protected AudioCDs, as they will “confuse” Windows as soon as the OS tries to access the disk.

In other words: For the complete “CloneCD coolness” it is worth trying to get CloneCD run in its “natural” mode. [/B]
CloneCD and the VIA Bustmaster drivers have never liked eachother … I’ll test here to see what CloneCD does.

Like I thought… CloneCD stopped working :frowning: But the worst part is that I can’t uninstall the drivers anymore. When running the setup again and select uninstall the computer hangs at restart giving a fatal error. Then I can only choose to restart in safemode (which also hangs) or go back to the last working setup with the VIA drivers installed :frowning: Figures; solve one problem, up pops another! Heheh it keeps us busy… Maybe I’ll a fresh install this week. I was planning to switch to the Dutch version of XP anyways :slight_smile:

Damn! I’ve got some CCD work todo now! :mad:
I thought, ah, just uninstall the drivers and burn a disc with CCD, then install the drivers again. Guess not! :frowning:
Gonna try it anyway. :stuck_out_tongue: (lets backup first shall we?)

Indeed… I’m also looking for a sollution but I don’t know if there is one :frowning: I got the drivers uninstalled though by using XP’s system restore which resetted my system to December 13th when the drivers hadn’t been installed yet…

After uninstall I was forced to reboot my sys. When I did the sys hang halfway. So I was forced to go for the hard reset. After booting again CCD said some driver was corrupt so I reinstalled CCD as well.
Now I’m back in Pio-mode with my Plex but, I can burn with CCD again. :stuck_out_tongue: (Made one copy so far)

But now?! I’m not planning on doing this every time I want to use CCD! :mad:

First I tried burning normaly with CCD and it failed upto 2 times. I got the error:

  • [b]Writing to cd failed: MEDIUM ERROR: NO SEEK COMPLETE (3:0x02:x00)

Then I tried burning with CCD but when in Safe Mode (WINASPI32). I manage to get the cd burned, but I couldn’t read it. :mad: Damn!! :confused:

The most strange thing is, that I could burn with CCD while using WinXP. And now it just doesn’t work anymore! Didn’t change anything or like that, it just didn’t work anymore one morning I woke up! :frowning:

Hmm, I’ve been following this thread for a while and noticed that my crappy Sony CRX100 burner shows PIO 4 during boot up but in Win98, I have DMA enabled. It’s set as slave on IDE2 with the Toshiba DVD as master. The Toshiba shows as ATA 33 during boot and also has DMA enable in Win 98. Is this the way it should be or is something messed up?

My Plextor 24x burner can’t get here fast enough:) Should be Friday at the latest.

Thanks for the help and hope you guys get your problems fixed.

Oh, running a 1.4 Tbird on an Abit KG7
256 PC2100 Crucial, etc.