PIO MODE ONLY on Plextor PX-755SA Need help

Howdy ya’ll

First post here I’ll try not to sound too stuupid.
Also, forgive me for the long post. I want to give the
pros and geniuses here as much info as i can remember.

I have a PX-755SA purchased in an emergency about a month ago for
projects that existed on a friends relatively slow external HDD.
So when it was taking 45+ minutes to burn 4.2gigs I thought must
be the source data is slow. Then Last weekend I tried to start
clearing off one of my other drives. Its a Western Digital the one
with the big cache and HD tach sez its got about 45MB transfer
at that area of the drive. My Last burn took 70mins for a full
4.3 Gigs on a Verbatim single layer DVD-R. Then I tried a
Verbatim DVD+R-DL with 7.9 gigs that took 41mins Burn-Proof on
both burns hit over 300 times. PTPro said last actual burn speed
was 8X on the Single layer.

Anyway long story short I can’t get my PX-755SA to get out of PIO mode.
I have an ASUS A8V-E Deluxe, 1Gig RAM, AMD 3500+ (Winchester),
I have the latest ASUS BIOS 1012, and Latest Firmware for the
Plextor 1.04, SATA RAID is disabled or rather in IDE mode.
I understand NOW of course that not all optical drives work
with SATA ports on motherboards. And I have heard that IDE
controller cards are not a good thing for Optical drives either.
I have Plextools Pro and have tested a burns with the PI/PO error
test and never got a PO error and PI errors never moved above 30-50
on the default test graph.
(Stands to reason the drive is working otherwise right?)
I purchased the drive 37days* ago *(including today)
I don’t think I can return it. :sad:
So My questions are: (in no relevant order)
What can I do to get my PX-755SA running in DMA mode?
Can I get an SATA controller card to run the PX-755SA?
Are there just drivers that I could install to fix the issue?
What would you do?

ThanX for any input. No really thanks
SOUNDnPicture

I’m also going to submit this to the plextor threads See if any of
those guys have some ideas

WORD UP to AVID for their incredible ISIS Unity Thats’ one baddass System. Everybody in Broadcast TV land knows whut up!

Welcome to CDF.
Check ot this thread, it will help you get your DMA on.
http://club.cdfreaks.com/showthread.php?t=101616

If all other methods fail here is a registry fix. I would do this only if the normal methods don’t work.

Xpost :frowning:
see http://club.cdfreaks.com/showthread.php?t=185967#post1485696

Please do not do this again; cross-posting is against the rules, and you can see why.

Closing this thread - discussion can continue on the link Mciahel quotes above.