PIO MODE ONLY on Plextor PX-755SA Need Help, Please

Howdy ya’ll

First post here I’ll try not to sound too stuupid.
Also, forgive me for the long post. I want to give the
pros and geniuses here as much info as i can remember.

I have a PX-755SA purchased in an emergency about a month ago for
projects that existed on a friends relatively slow external HDD.
So when it was taking 45+ minutes to burn 4.2gigs I thought must
be the source data is slow. Then Last weekend I tried to start
clearing off one of my other drives. Its a Western Digital the one
with the big cache and HD tach sez its got about 45MB transfer
at that area of the drive. My Last burn took 70mins for a full
4.3 Gigs on a Verbatim single layer DVD-R. Then I tried a
Verbatim DVD+R-DL with 7.9 gigs that took 41mins Burn-Proof on
both burns hit over 300 times. PTPro said last actual burn speed
was 8X on the Single layer.

Anyway long story short I can’t get my PX-755SA to get out of PIO mode.
I have an ASUS A8V-E Deluxe, 1Gig RAM, AMD 3500+ (Winchester),
I have the latest ASUS BIOS 1012, and Latest Firmware for the
Plextor 1.04, SATA RAID is disabled or rather in IDE mode.
I understand NOW of course that not all optical drives work
with SATA ports on motherboards. And I have heard that IDE
controller cards are not a good thing for Optical drives either.
I have Plextools Pro and have tested a burns with the PI/PO error
test and never got a PO error and PI errors never moved above 30-50
on the default test graph.
(Stands to reason the drive is working otherwise right?)
I purchased the drive 37days* ago *(including today)
I don’t think I can return it. :sad:
So My questions are: (in no relevant order)
What can I do to get my PX-755SA running in DMA mode?
Can I get an SATA controller card to run the PX-755SA?
Are there just drivers that I could install to fix the issue?
What would you do?

ThanX for any input. No really thanks
SOUNDnPicture

WORD UP to AVID for their incredible ISIS Unity
Thats’ one baddass System. Everybody in Broadcast TV land knows whut up!

Hi,

Have also installed latest Via Hyperion Pro drivers? That is at least worth trying. SATA on VIA based mainboards is “slightly different” (I by myself run a MST K8T Neo2-FIR).

I understand NOW of course that not all optical drives work
with SATA ports on motherboards. And I have heard that IDE
controller cards are not a good thing for Optical drives either.
My Samsung SATA drive works fine with my Promise controller. IDE cards are not suitable, if they support RAID. Non-RAID cards should work, atleast recent adapters.

(…)Are there just drivers that I could install to fix the issue?
Yes. Try latest Hyperion Pro drivers from www.viaarena.com

Michael

Just a quick question to add.

When I just checked this on my PC I found that the primary IDE channels (hard drives) were both in ultra DMA mode but on the secondary channel only the device 0 was on DMA and the device 1 was in P10.

Would I be right in assuming that device 0 is the master device on that channel ie my Burner? The other device is just a dvd rom so really not too important.

The SA won’t show on the IDE controller. It may show up under SATA or even SCSI.

The mobo uses a VT8237 chip. Early versions only ran in PIO mode. Later versions of the chip are reported to have no problems. Run the latest drivers from VIA. If that doesn’t work, get a PCI controller such as the Adaptec or other controller listed on the Plextor mobo compatibility list.

Thanks a lot for the info.

I tried the latest Hyperion Pro drivers… and still no go. Only got about a
0.7-1.3X burn on a DVD+R took 70 mins to burn a data 2.7GB. So from
your other suggestions I should be looking at a PCI SATA controller card.
On the Plextor site an Adaptec and two promise tech cards are recommended.
Based on your experiences which of the two manufacturers
would you purchase?

Again I have an ASUS A8V-E Deluxe (VIA chipset of course, AMD64 3500+,
1GB RAM ASUS BIOS 1012, PX-755SA firmware 1.04
The primary use of my system is to edit video with AVID Xpress Pro HD
and mix with PRO Tools LE through an Mbox.
For those unfamilar with the Mbox its an audio interface that
connects via a standard USB1.1 port.

If I do go with the controller card are there any potienal conflicts
that I should be made aware of; rendering the card useless for
my purposes. Or for that matter somehow affecting the
firewire or usb ports on the system. As far as I am aware such
a controller would not affect those but I would like to know if
anyone has run into such an anomaly.

Like I’ve said before
What would YOU do?

Thanks
SoundNPicture

The adaptec card is good. I have a generic board with a Silicon Image 3112 that works well.

Thanks for your help. I just recently purchased a Promis SATAII150 Tx2 controller card and after a quick install my PX-755SA is a running beauty. Amazing…went from full DVD taking 60-70mins to burn to full disc finished in 5:56min OUTSTANDING.

Thanks for you input and suggestions.

Hi all,
I got a new 755-SA and I’m experiencing a similar problem: it takes 20 minutes to burn a full DVD5 ISO at 8x. I’ve tried only wth Verbatim Avanced AZO 8x DVDs.

My config is:
AMD 3800+ Venice
Abit An8 Ultra
2048 Team Group Xtreem DDR500 Ram
36GB WD Raptor + 200GB WD Caviar HDDs
No SATA raid activated

Any help or suggestion?
Thanks!

ps: I’d rather not go for a SATA controller card… they’re too expensive!! :x

Try the latest nforce4 drivers. If that doesn’t work, try the MS drivers. If that doesn’t work, the chipset probably does not support ODD.

That worked.

2.55 GB written in ~ 5 minutes @ 8x with no buffer stop&go :smiley:

Thankssss!
:bow: