PIO/DMA..samsung sh-s186L HELP!

I have something odd going on… i just installed my dvd buner, and its doing odd things. ive changed SATA cables, tried different SATA ports on the computer, checked the BIOS settings, everything i can think of. I finally got it to work, but get this: It only work in PIO mode! if i set it to DMA mode, and I insert any kind of disc whatsoever, it never reads it. under device manager and my computer it correctly identifies the drive, and device manager says its working fine. but autoplay never brings anything up, and when i click on my computer with a disc inserted into the drive, the my computer window shows up but hangs. you check it with ctrl+alt+del and it shows my computer as not responding. it does however, seem to work fine under PIO mode. Any suggestions!?

DFI Lanparty UT NF4 motherboard
AMD Athlon 64 3700+
SATA seagate harddrive in SATA 1
SH-S183L in SATA 3
Windows XP Pro 64-bit
no other drives, well built machine.

have you tried deleting the drive and letting your system reinstall it! to see if it corrects your dma issue if not its worth a try!

I have the same issue with this drive. I installed DVD Decrypter 4 and it told me I wasn’t in DMA mode so I let it update it to DMA. Well that broke the drive. All attempts to burn resulted in “Communication Error while writing”. Not being familiar with this stuff I started searching around and figured out how to set it back to PIO mode and boom, everything works again. I did try updating to the latest firmware as well, but that did not make the issue go away. I also tried many flavors of DMA in the BIOS (single, multi, Ultra) and all resulted in the same problem.

Is there anyone out there that has this drive working successfully in DMA mode?

Hi and Welcome!

not all software can properly detect the DMA mode of a SATA drive, since there are lots of different controllers used, which do or do not report back if the attached drive is running in any DMA mode.

Please tell us, what SATA controller you are using, also what operating mode (RAID/non-RAID) is set, and what drivers are used.

Michael

Mike,
Thanks for the reply. It’s running in a non-RAID setup.

Controller: Standard Dual Channel PCI IDE Controller - Primary Channel

Driver:
Microsoft Drivers Version 5.1.2600.2180
atapi.sys
pciide.sys
pciidex.sys

Hi,[QUOTE=unchoops23;1951841]
Thanks for the reply. It’s running in a non-RAID setup.

Controller: Standard Dual Channel PCI IDE Controller - Primary Channel[/quote]non-RAID is good :slight_smile:
The Standard PCI IDE controller means, you are running MS basic controller driver. I have no idea how this handles DMA/PIO.
What kind of hardware is that really? I am asking since there are some SATA controllers, that don’t support optical drives properly. If you don’t know exactly, please check your motherboard manual.

Michael

Good question man. It’s an MSI K9 Platinum SLI mobo and all the book says for Sata is “6 x SATA-II (Serial ATA II) for six SATA300 devices”

Here is the chipset information:
Chipset

• NVIDIA ® nForce 570 SLI Chipset

  • HyperTransport link to the AMD Athlon 64/Athlon 64FX/Athlon 64 X2 CPU
  • Supports 2 PCI Express x16 interface (2nd X16 slot runs at X8 speed) / 2 PCI Express x 1 connection
  • Independent SATAII controllers, for six drives
  • Single Fast ATA-133 IDE controller

Hi,[QUOTE=unchoops23;1951893]Good question man. It’s an MSI K9 Platinum SLI mobo (…)

Here is the chipset information:
• NVIDIA ® nForce 570 SLI Chipset
[/QUOTE]You may try Nvidia’s SATA drivers then. Make sure, you’re using the latest version from Nvidia.com The drivers may be part of a bigger chipset drivers package.

Michael