PIE/PIF scanning freezes on both BenQ DW1620 and DW1640

vbimport

#1

So, I’ve gained two used (but in great state) drives DW1620 and DW1640 specially for disc quality scanning. In the working computer both drives scan perfectly and without problems, but in my home computer both of them have same problem - scanning freezes at same place on both drives and on any DVD-disc - at 262 Mbytes with scan speed 16x, at 203 Mbytes with speed 12x, at 135 Mbytes with speed 8x, at 102 Mbytes with speed 6x and at 68 Mbytes with speed 4x. I’ve tried Nero CD-DVD Speed, Opti Drive Control, DVD Info Pro - same results with all of them.

Transfer rate test and “scandisc” test work perfectly. DVD burning (even DVD+R DL burning!) also works great.

My motherboard is ASUS M3A78-CM, working computer’s motherboard is ASUS M2N-SLI (nVidia IDE drivers are installed). I’ve tried to replace standard Microsoft IDE driver with AMD IDE driver but results are the same. OS on home and working computer is the same - WinXP Pro SP3.

I really don’t want to change motherboard on my PC just for disc scanning capability - is there a different solution?

BTW, my LiteOn drives with IDE and SATA interfaces scan PIE/PIF without problems.

Sorry if this problem was discussed before, I’ve used search and found only this thread with similar problem: http://club.myce.com/f92/benq-dw1650-stops-scanning-nero-cd-dvd-speed-1-2-a-192891/

Thanks in advance for any useful hints.


#2

I have completely reinstalled Windows - quality scanning still freezes at the SAME places :frowning: What I should to do to make it work? Except buying a new motherboard.


#3

You could fiddle with your BIOS settings (fiddle: a great word, I know :p) to see if something in there might help you out.

Outside of that, you might have to purchase an add-in PATA controller card to avoid using the controller in the AMD chipset. There might be some bug in the AMD controller or its configuration that you can’t fix. (It happens to every manufacturer with one product or another).


#4

[B]Albert[/B], thanks for the idea - I will try to get PCI PATA controller board next week, or even PATA-SATA converter board (I want to try connect these BenQs via eSATA using the interface converter).


#5

nVidias based mobos never manaded to tackle this issue.

Are you on nVidia?


#6

[B]pinto2[/B], my home computer’s chipset is AMD 780V and working computer’s chipset nForce560. PIE/PIF scanning freezes at home but works great at the work :frowning: This happens only with BenQs and doesn’t happen with LiteOn and its clones.


#7

Unexpectedly I’ve found the solution - I’ve upgraded my DW1620’s firmware from B7V9 to B7W9 and downgraded my DW1640’s firmware from BSRB to BSLB - and they now can make beautiful scans on all speeds without any freezes. I’ve tried to flash them again to B7V9 and BSRB and the problem returned, and when I’ve flashed them again to B7W9 and BSLB and the problem was again solved.

Probably some Nexperia firmwares just works strangely with my AMD 780V chipset.


#8

Oh, there were weird bugs with some firmware. It affected some more than it did others; in most cases, when the drives would pause, they would resume just fine…but it happened multiple times for a lot of people and (was understandably) annoying. :doh:

Congrats on figuring out the issue. :slight_smile: