Phillips DVDR16LSK not recognised

I have just purchased a Phillips DVDR16LSK, Burner and Printer in one. Problem is, My puter doesnt recognise it? When I reboot it says fouond new hardware, but the new hardware it finds is my existing cd writer! I ask it to scan for new hardware and still no DVD. I need help please. :confused:

System:
AMD Athlon 2200+
1.8 Ghz
60GB Harddrive
Windows XP service pack2

In many cases, with modern hardware - you should NOT plug the device before you install driver cd. You just need to read manual carefully. For example, my comp won’t install the hp 1215 printer, if I point it to the disk or any other way, expect to installing the cd first.
Good luck.

Junglemike is absolutely right. In your case first uninstall the existing driver for the equipment (Device Manager), reboot. And from now on do as junglemike said.

Hi and thanks for the advice.I followed exactly what the manual said and it has not worked. It just does not recognise that I have a drive there?. When I reboot, I can see that theres power going to it, by the flashing light, but thats the last thing it does.

You sure you have jumpers set right? What IDE drivers are you using?

Now youve completely lost me!! That’s why i’m in the newbie forum :eek:

Welcome and sorry if i lost you…For IDE drivers > Go to system properties. >Device manager. >IDE/ATAPI Controllers. >Primary/Secondary IDE Channel. >Properties. >Driver Tab. Jumper settings here > http://club.cdfreaks.com/showpost.php?p=1124351&postcount=3 Also read some in the FAQ’s here for more info on trouble shooting :wink:

Edit: Also check your DMA settings here > http://club.cdfreaks.com/showthread.php?t=101616
And look in the BenQ/Philips Forum > http://club.cdfreaks.com/forumdisplay.php?f=92
Hope this helps