Philips8801-nw02 Firmware/freecom18h9 Fr01 Firmware

vbimport

#1

No1.Problem I recently bought a Freecom DVD+/- RW18H9 (DL & RAM) usb2 with FR01 firmware, but all the discs I tried fail, I used the following types of disc:

Verbatim -R 16x
Tuff -R 8x
Ridisc DL +R 8x
Philips 2.4x DL

Looked for firmware on the Freecom Support/download site for possible upgrade, but my machine is not even listed, the nearest was a DVD+/- RW16H9

No.2 Problem, My Philips 8801 with NW02 Firmware will not burn/record on D/L discs, I have tried two different types - Ridisc DL +R 8x
Philips 2.4x DL, according to the Philips Intelligent firmware download agent, I am not allowed to update the NW02 firmware, and any place I looked always mentioned another firmware that the machine has, but not NW02, Can anyone help, in terms for a beginner, can write to my email addy walmat@hotmail.com or on forum, many thanks


#2

Try with Verbatim +R DL media, they surely will work beautifully.

Avoid Ridisc and others.


#3

Hi again Chef,
With regard to the Philips, I have seen the forum suggestion about the cross flashing with the Benq1650, tried it but unfortunatley it will not allow me to, saying this drive is not allowed to be upgraded
If you know some other way of changing the firmware I will be most grrateful

Once again, many, many thanks,
Walmat159


#4

Try the link I’ve sent you via pm, and just post into that threads to get more useful flashback.


#5

hi all i have just bought freecom 18xdvd rw external dvd writer from pc world, model code ise aaa , in win xp system/hardware this is shown as rw 18h9.

erasing a ridisc +rw disk i got illegal disk message using nero 6 se, i dont think the freecom likes ridisc disks, my tatung dvd recorder (+r or +rw) does not seem to recognise the rw vertions.

i would be interested to know if there is a firmware upgrade for this model and where i can obtain it.

ps freecom works fine with tdk +r and +rw disks.

thank you


#6

Hi Froggy,
I have been unable to get updated firmware, as you may have read earlier there is a lot of stuff it will not burn/record on, I also purchased my machine in PC WORLD, get them to check it out, and if they can’t do anything, get a replacement, in the past I had an internal 16x Emprex, and after using their firmware download I was able to burn any type of disc, no problems, quite efficiant


#7

Afternoon all.
Just a quickie ref Freecom 18h9.
Ive found the problem when burnin using different disc`s.
Its not the 18h9 but the software your using to burn ie nero.
Try using ulead burn now that came with the 18h9 and all should work fine as i did after many coasters.
Happy burning folks :slight_smile:
Gunnyy