Philips sdvd6004 won't burn (but will read)

vbimport

#1

Hi, I recently purchased an upgrade drive for my Dell Inspiron 5150: the philips sdvd6004 dvd/cd-rw. It’s supposed to be able to write DVD+R and DVD+RW, but I can’t seem to get that to happen. :a

What seems so strange is that the drive is working! It reads CDs and DVDs, and it even writes CDs. But when I put in a blank DVD+R, it says there are 0 MBs free on the disc. I have Adobe Encore, which I tried using to burn DVDs, but it says there are no devices in the computer that can write DVDs.

I updated the driver (I think), but running Firmware 1.6 which I downloaded here . When I rebooted, I got a little message saying new hardware was found, but it still doesn’t recognize writable DVDs and Encore still tells me I have no device that can write DVDs.

Please help!


#2

Can no one help me with this? :frowning:


#3

i cant believe you “upgraded” to a 2x dvd burner and without dual layer what a waste, anyway its not a driver its firmware no driver needed windows generic one is good enough , sounds like adobe encore does not support your dvd burner try other software


#4

OK, thanks. I don’t know that much about hardware so I picked up something cheap on ebay.

What sort of thing would you recommend instead (dual layer means DVD blue?)?


#5

No, dual layer is not blue ray. And you don’t necessarily need a dual layer drive, you just need a good 16x dvd burner with good media support. There are many that will work, including NEC, LITE-ON, Plextor, Pioneer, LG, BENQ.