Philips SDVD6004 and Benq 8x media

Can anyone help me?

I purchased Benq 8x DVD+R media for my DVD burner. They worked well on the first few burns, so I went back to use up my older Memorex 4x DVD+R’s. Now that the Memorex media is used up, I tried the Benq and cannot burn to them. The burner does not appear to recognize the media! I bought more Memorex media, and there are no problems.

I can’t understand why the Benq media worked before, but not now!

I would appreciate any and all help on this problem.

Thanks in advance.

I would first try to update the firmware to 1.06 (click here) or direct download link here. Then after you flash your firmware check back with the BenQ DVD+R media and let us know how it goes.

Note: the direct download link is from Dell.com, so the burner came from a dell laptop maybe?

Burner came with my DEL 4600C (Compact tower so no room for full height burner).

firmware was flashed but still won’t work with the Benq DVD’s.

I’ve tried different DVD burn software Roxio, Sonic, Ulead, but always unable to burn to the Benq but OK to the Memorex!

The fact that they used to work is what puzzles me!