Philips PBDV1640P failing halfway thruogh discs

vbimport

#1

I’m a rookie here so any help would be most appreciated, OK I got an OEM Philips PBDV1640P and stuck it in My PC, it reads and plays DVD’s perfectly, but when I try to burn a movie it fails about halfway through (but in a different place every time), I tried different Brand of Media and got same problem, tried DVD+R and DVD-R but it still failed, now this is the odd thing, I then got a DVD+RW to save wasting disc’s and it burned perfectly??, I’ve tried different burning software but it made no difference, I cant seem to get any error detail except in Nero it gives a fixation error.
Please Please Please HELP !!! :confused:


#2

if you are using Winxp go to Admin/tools/services and disable Imapi cd-burning com software.That should fix it.


#3

Thanks Happynow, I’ll try this, do you think I shoud update firmware from 2.2 to 2.5 ??


#4

Don’t know about the firmware as mine is a 1640p but with b2.2 (OEM) firmware and it won’t let me change it to the p firmware. Mine doesn’t have the fancy lights on the front.


#5

Yes Mine IS the OEM Also, it doesn’t have fancy lights either, I will try your suggestion with the imapi,
Many thanks


#6

put the BenQ firmware B7P9 or B7S9 i it.
much better than the philips firmwares.


#7

Did the suggestion work Uch ?


#8

I cannot try suggestion until I return home this evening, but if it does I will let you know.


#9

I put the b7s9 on but haven’t tried it out yet. Will burn one later to see how it compares to the B2.2


#10

I’ve tried this but it didn’t do any good, tried to upgrade firmware but the exe wouldn’t work, I did notice this time that the error was a “Communication Failure” this time. Any more ideas please anybody ?? :confused:

I Forgot to give specs, PC is XPprosp2 256 ram 2.2GHz asrock board


#11

What software are you using to burn and what version?
Is DMA mode 2 enabled?
Are you burning the Movie on the fly or from hard drive folder?


#12

Yes DMA2 is enabled, I’m using Nero 6.6.0.1 and It’s a folder from my hard drive, thanks again.


#13

What kind of media are you burning, post your media code with DVD Identifier or other program?


#14

If you guys have flashed to any retail BenQ firmware and had bad results, just flash again to the L9 firmware (overwrites everything), then flash it to the P9 or S9 firmware. S9 has a slightly higher occurance of choppy playback on some discs, but if the flash takes right, then S9 will give you better odds at data integrity.


#15

OK guys here’s an update, I brought the drive into work and installed it into my Compaq evo deskpro and it works fine, so it looks like it’s my hardware at home is the Problem. It’s a self build but Everything seems in order. Any Ideas?


#16

Maybe change the IDE cable (new one), defrag your C:\ drive. Are there drive’s that have cable select jumper setting on. Just check everything possible on your hard drive and cdr/dvdr drives.


#17

Here are a few ideas:

  1. Is the power supply on your computer at home a good one?

  2. Are you using rounded IDE cables (I’m convinced they may be a “bad” idea).

  3. Be careful disabling Imapi. I know this works fine for a lot of people, but my system started blue screening right after a burn when I disabled it, so I had to turn it back on.

  4. If your system is AMD based with Nvidia nForce drivers, go to the Control Panel->Add Remove Programs->Nvidia Drivers and remove just the IDE driver.

  5. Is there any other device sharing the secondary IDE port where your burner is attached? If so, and if you can, temporarily remove it so you can rule out any possible conflicts with it.

  6. Check your bios (at boot time) and make sure that the primary and secondary IDE ports are all set to AUTO and are not disabled.

  7. Is there anything unusual about your system at home - something that’s installed in it that’s not installed in the Compaq at work?

  8. Go into your bios and disable any onboard peripherals that you do not use. This will include COM1, COM2, and possibly your parallel printer port. This will free up any IRQ’s that these devices are claiming, making them available to the system for other purposes. Perhaps your problems are happening due to IRQ sharing (I don’t really know much about this, however).

  9. Uninstall ALL burning software that you may have accumulated, and then reinstall only the software that you are currently using. Some of this software will install fairly low level drivers that can wreck havoc when mixed with other software that installs a competing driver.

  10. Good Luck!


#18

Thanks Guy’s I finally got this working by updating the IDE chipset driver on my motherboard to the latest version. Once again thanks a million for all your help.

UCH
Go raibh maith agaibh.