Philips PBDV1640p and Asus motherboard

vbimport

#1

Hello to this forum!

I am new to DVD burning and have just purchased the OEM Philips DVDR1640 from Ebuyer. The drive is reading fine and I’ve burnt an Audio CD on a CD R disc. I have some Memorex DVD+R 1x/4x and this is where the problems start! I have searched extensively looking for solutions as to why these discs wont burn, (the process doesn’t even start). I have tried Nero, NTI. Ashampoo. I have enabled DMA. I have downloaded every firmware update I can find (including benq) but they all say “Drive not supported” so I haven’t been able to update firmware.

I have an Asus A7N8X deluxe motherboard, Athlon 2700, 768DDR Ram, 120gig HD, XP proSP1 OS. I saw a small mention of problems with Nvidia but couldn’t see the solution. Does anyone know if there is an issue with this drive and the above motherboard with the firmware updates? I am going to purchase some DVD -R tomorrow but would still like to be able use the ones I already have!

Any help at all greatfully received!

regards
hay331


#2

hmm, ok, so it seems no firmware updates are out yet
Philips DVDR1640P - No Firmware Updates Available
(Known Firmware: P2.1, P2.2, P2.5) is all i can find

let’s start at the obvious - will the drive recognise a movie dvd when inserted ?


#3

Philips DVDR1640P - Firmware P3.2 here: http://club.cdfreaks.com/showpost.php?p=822717&postcount=182

Philips PBDV1640P - Firmware B3.2 here: http://club.cdfreaks.com/showpost.php?p=828611&postcount=203


#4

I’m certainly no expert but I had exactly the same problem when I first got my computer. It came with nero 5.5.10.53 installed and it would not recognize my DVD burner only the CD burner.

When I upgraded to Nero 5.5.10.56 it suddenly recognized my DVD burner! Only then was I able to upgrade the firmware.


#5

Thanks for swift replies!

Yes it does play DVD movies. I have also used the Nero Info tool and it does see the drive. I have burnt an ordinary audio CD R . I have attached the Nero Info to see if that sheds any light. It could just be the Memorex +R discs that I bought which is annoying, I hate paying cash for things that dont work! I will try with -R over the weekend.

regards
hay331

NeroInfo.doc (43.5 KB)


#6

I have tried to update firmware but no luck, just keep getting an error message. When I go into device manager I noticed it is a Microsoft driver on the DVD drive. Has anyone else had this problem trying to update firmware. I have the latest version of Nero by the way.

regards
hay331


#7

Just an update that might help others struggling with DVD burning stuff!
After reading some other posts I decided to try the DVD Santa software. It really is a good programme, I had some home VHS movie that I ripped to PC (Dazzle video Creator 150). It was a few simple steps to convert then burn onto both Memorex CD+R and Datawrite CD-R. The discs play on my PC and on my DVD player. A free, fully working trial can be downloaded here, http://www.dvdsanta.com. Highly recommended especially for newbies!!

I haven’t managed to update the firmware for my drive yet but am waiting for a reply from Philips.

regards
hay331