Philips PBDV1628B Jumper settings

vbimport

#1

Hello all, just registered so hope you guys and girls can help me. I bought a new dell and have the 80 wire IDE cable, have the standard burner connected to the end of the cable and I have added the philips pbdv1628b to the second place on the IDE cable. However all is not well, the philips drive is reading and writing at an incredibly slow rate and I heard somewhere that I need to set this drive as a slave for it to obtain its full speed. Is this correct, or is it rubbish, I dont know so if it is then could someone tell me the jumper settings as I have searched google and nothing came up, even the philips support pages don’t have anything…!

Many Thanks in advance

Paulobeato :smiley:


#2

Doesn’t it show the jumper setting for master, slave, CS etc on the drive itself? Most drives do, near the back, near the IDE connector.

Welcome, BTW :slight_smile:


#3

I thought that, but strangley it doesnt…

Any ideas


#4

Drat. Sorry, other than that, I have no idea. I even tried Googling it for you. :frowning:


#5

Thanks for your efforts, I cant believe that even the philips website doesnt have anything…

Thanks again
Paulobeato


#6

Have you checked you are in DMA and not PIO mode.


#7

Hi :slight_smile:
Manual for your drive here.
via Philips website.
If you have problems, for jumper settings see piccie.
More likely DMA, how to check here.


#8

Well spotted, zebadee (the manual/settings) :clap:

I was gonna say about DMA, but didn’t want to address it til the jumpers were sorted out. :slight_smile:


#9

More likely DMA, how to check here
I knew there was a link somewhere - nice one zebadee :bow:


#10

Hi :slight_smile:
I always thought you had a thing about jumpers. :stuck_out_tongue:


#11

Now, now… :stuck_out_tongue: :bigsmile:


#12

I don’t know. Post your picture & they all start getting saucey.


#13

Nah, it’s just a little joke because we’re from the same city (same part too, it would seem), LOL.


#14

Thanks for your help chaps, the dvd drive is now up to full speed again.

Paulobeato


#15

Pleased to hear it’s all working correctly :slight_smile: :clap: