Philips "no disk" or "unknown data" problem

Hello Everybody,
After 2 years of almost flawless service, I’ve recently run into the
“no disk” and “unknown data” problems with my Philips DVDR-75. ( +R disks)

Here is what I’ve found out :

In my case, it seems there may be a link with the media brand.
I’ve had the problems reading some Tayo Yuden (T02-00) disks.
My older disks, Memorex (MCC 003), are all, so far, problem free.
By using Dvd Decrypter, an ISO copy of the problem disk onto the Memorex media makes a Philips readable disk.

( All my +R burns are ISO, using Dvd Decrypter, at 4X, booktype set as DVD-ROM. )

It seems that after playing the copy Memorex disk, some how, the DVDR-75
regains the ability to detect and play the “problem” TY disks,
…BUT…only until the unit is powered down. very strange. :confused:
Maybe it recalibrates the “laser power” upon each power-up cycle? ?

I’ve also discovered a possible work-around.

Powering up the unit using ONLY the “Play” button,
( w/problem disk already in the tray )
will give me a maybe a 1 out of 5 chance, that it will detect & play the problem disks.
( if not, I get either “no disk” or “unknown data” )

I still have a few additional tests to try out, when I get the time.
If anyone has any suggestions or comments… I’d sure appreciate them.

My firmware is ff16f. Tomorrow I’ll update to ff16k and see if any of the patterns have changed.


Have had the ‘no disc’ problem with two Philips machines but only with commercially recorded DVDs. +R and +RW still played fine. The first time with a DVDR880, was replaced by a DVDR70 which went the same way. however, it was out of warranty and Philips wanted £140 to repair it :frowning: Have got another DVDR70 which is playing disks fine. Long may it last.


Have a look at “Philips DVD spare part number” posted by myself about three weeks ago.

Unfortunately the syptoms you describe sound like the laser assembly in the drive has started to fail.

The symptoms usually start with the recorder failing to recognise pre-recorded disks, then you get “DISK ERR” during recording, which becomes more frequent. Then it becomes almost impossible to record more than half an hour of programme.

The symptoms are confusing because some DVD+RWs fail more readily than others.

If you look at the posting I mentioned above, you will see that I have tried to obtain a replacement drive assembly for a DVDR75, but the authorised stockist (Dutch West) say the part number I quoted is no longer available. Also be aware that Philips will charge £141 to collect and return the faulty machine, but they still make the charge even if they cannot fix it. (Yes - I couldn’t believe what Philips were telling me either, which is why I don’t want to send my DVDR75 to Philips when they say they can’t provide replacement drive units. Although I suspect that Philips has a stock of drive units for their own use only.)

The earlier posting I referred to was actually a request for the part number of the drive unit in a DVDR75. If you open up your DVDR75 and look at the rear of the drive unit and the part number is different form the one in my earlier posting then you may be able to get a replacement from Dutch West.

Please let me know how you get on.


UPDATE on Philips unreadable disks…
Some may find this helpful

The firmware upgrade to ff16k seemed to make no noticable difference in reading disks.

I wanted to find out if temperature might be a factor with the reading problem.
( It might explain why the problem disks would read OK only after playing a non-problem disk )

So I did a few tests with 5 randomly picked “problem” disks.
I first tried to play the disks on a cold DVDR75…then, leaving it powered up, …every 15 min.

Here are the results:… ( ND = NO DISK … UD = UNKNOWN DATA )

           --   COLD   15min 30min 45min  1hr  1:15  1:30 1:45  2:00

      1   -       ND    --   UD      -- ND   --  OK  -  OK -  OK - OK - OK - OK 
      2   -       UD    --   UD      -- ND   --  OK  -  OK -  OK - OK - OK - OK
      3   -       ND    --   ND      -- ND   --  OK  -  OK  - OK - OK - OK - OK
      4   -       UD    --   ND      -- ND   --  ND  -  ND  - ND - ND - OK - OK
      5   -       ND    --   ND      -- OK   --  ND  -  OK  - OK - OK - OK - OK

For most unreadable disks, there seems to be a needed warm-up of at least 45 min.

It does not fix the problem…but at least it seems to work. :slight_smile:


Mikel - your observations and the time you have taken to make them are laudable - in fact I found very similar behaviour with my DVDR880 after its first repair.

However these are almost certainly the signs of a failing unit, and unfortunately the time taken to warm up will continue to increase, and eventually there will never be any disc recognition.

I’d like to point you towards some back-door entry point for a FOC Philips repair, but you guys in the US are very poorly served it seems. Its rather sad to see reports of DVDR75s beginning to fail in this way, since the vast majority of this phenomenon was associated with the 8x0 series.

I’m afraid I have to agree with you. I believe that my machine is slowly
approaching its demise.
Although hunting for “patterns” has always been a useful & fun tactic for troubleshooting, I suspect that my time will now be best spent by looking
for my next recorder. I like using, & hate to give up the plus format,
but I am also now eyeing the Pioneer 520H.
( I like all the picture-adjustments, picture quality & ability to edit adverts )

take care,

I have a Philips DVDR-72 that was purchased “refurbished” from Philips direct about a year ago.

Just recently it began to have “disc error” messages following the step to “finalize” a disc.

This occured using Ritek brand DVD+R discs,
note…however over 50 of them were recorded from the orginal 100 pack spindle without ANY problems.

I too wanted to determine if it was the “media” itself or the DVD recorder. But in addition, I thought it may of even been related to a problem with the orginal source movie (protection or something)

Here’s what happened:

First movie (M1):
Took the disc with “disc error” / “unknown data” and used PC to copy it with Roxio Easy Media Creator 7.0.
(a copy automatically “finalizes” or “closes” the disc, which the player was unable to do).

Using “creator”, the DVD “folders and files” were copied TO the SAME brand media (Ritek).
The copied disc DID play on a DVD player (portable Polaroid player, not Philips),
HOWEVER it had video and audio skipping after the 3rd chapter.

Next, tried a DIFFERENT movie (M2):

This also resulted in the same exact “disc error”, and was determined the
movie used was not a factor (as assumed for M1).
The 2nd movie (M2) was copied with Roxio CD Copier TO a “Memorex” disc instead.
This disc played PERFECTLY in the portable DVD player. (excellent!) :slight_smile:

I then took the first movie (M1) and copied that one to a Memorex DVD,
(again using Roxio CD Copy), and it ALSO played perfectly.
(unbelievable!) :slight_smile:

This reiterates what the orginal poster stated (thanks for sharing). :bow:

I did try putting the Memorex disc in the Philips DVDR72, and then the M1 and M2 disc error CD’s, but they still wouldnt play.
All in all I went through a TOTAL of (8) discs to get (2) movies that play.

Still have yet to determine if my DVD recorder is biting the dust. My best guess is that it is…since CDROM lasers don’t last very long (I have had 3 go out in the past).

One thing for sure, CD/DVD recording is almost rocket science! :eek:

I have had an DVDR70 for just over 2 years now (latest firmware installed), but recently I have started getting the EmptyDisc, Unknown data or Disc Err messages every time I put in a previously recorded +RW/+R disc. Pre-recorded discs work fine except for occasional skips. I also have found if the unit has been used for a while (had a chance to warm up) it will manage to read the +RW but not the +R discs.

However, when the EmptyDisc message occurs with +RW dics, I can still record, although I lose the original contents of the disc. When the recoding has finished it does a post format and the disc contents are visable and playable until I power down. If I power up immediately after powering down I get an one of the error messages again!

If I put this recorded +RW disc into a DVD drive or PC drive the contents are readable.

Now, this is a little confusing because the laser unit can obviously write to the disc at any time, and read from it until a power cyle is made. I am becoming very suspicious of Philips equipment (although I mainly own their stuff). I had to replace a 711 DVD drive because it kept saying it was locked out (and I hadn’t been messing with region codes etc). I spent weeks searching for a solution, in which time I brought a Philips 625 player (so far, very reliable), and then found a reset method on a forum which brought the 711 unit back to life.

After reading many of the forums on Philips equipment recently and comparing them with my own findings plants a seed in my mind. Do Philips build in a time limit into their equipment before thet start malfunctioning (say a couple of years) - if so it won’t do their reputation much good. I have just brought a Liteon HDD/DVD recorder instead of Philips because of my recent problems. (Yes, I do know there have been reports of problems with Liteon, but it seems a much more robust unit - and now very reliable. Time will tell)

This is a followup to my last post here a few days ago.
As stated, there were “disc error” and “unknown data” messages,
using a Philips DVD recorder.

Today I bought a new 25 pack of Maxell DVD+R’s (inkjet printable).

I recorded with 2 full discs on the player with NO PROBLEMS!! :bow:

So either the recorder problem is intermittent,
or there became a point in the 100 pack Ritek spindle
where the discs were faulty. I hope its the later.

Just glad that I don’t have to buy a new recorder,
…at least not this week. :slight_smile:

I have found the problem that gave disc err on my dvdr75, ist very easy to fix your dvdr, the problem is a cable bracket thats mounted upsidedown.´

  1. Open cd door and push the front that says "dvdr recorder"upwards to get it off.
  2. Remove the top cover 9 torx screws and lift the top off.
  3. remove 4 torx screws on the cdplayer gently loosen the wide cable and a power connector, it should now be possible to remove the player and turn it upside down.
    4 Locate the white plastic cablebracket that locted just under the lasertrollys travel
    and gently remove the bracket and turn it so that the side that was facing downwards now points up. notice that the thin side was facing up and made the lasertrollys movement to be hooked on the cablebracket.
  4. If you want to feel the problem you can remove the fan and cd holder on the other side off cdplayer this to gain access to the lasertrollys full travel an you should be able to feel when the trolley hooks on the cablebracket.

good luck dudes.

from Hans Sweden now a happy owner of a dvdr75 (that works).


I have just started to experience “DISC ERROR” messages with Maxell discs Ive been using. The same occurred from 2 different packages, both Maxell, printable, made in Japan.

Ive about given up on this product. I even took the advice of taking it apart to align the supposive backwards white plastic piece on the tracks, but was unable to locate it.

The discs do play, they record fine, they will not finalize.

Therefore, as an alternative until I get another device, I can record progs to DVD+RW, then copy the disc image to PC, then write to DVD+R…that will finallize the discs - alot of steps, but it works.

can anyone recommend a good progressive scan dvd player? its time to upgrade.

Hi, I’ve got the DVDR75 Model with the same problems, it’s not good news i’m afraid. Mine is insured and i described the problems to the Philips engineer and he knew exactly what was wrong- The Laser assembly, which was discontinued a year ago, so my machine will be “written off”, as it is not repairable. Sorry to be the bearer of bad news, Nigel