Philips DVDR985 Error Codes

I have a DVDR985 that was given to my by a friend. I finally got a remote for it and went through the setup. It played an original DVD for about five minutes and then the error occured, AB FFD0E6. Now it will not respond to any front panel or remote buttons. I have unplugged it for a day and plugged it back in and the display shows AB F0977 for a few seconds then goes to AB FFD0E6. I cannot upgrade the firmware for I cannot get the disk in the tray for it will not open. Has anyone seen this problem and could advise me what to do? Thanks! Bill B.

You will probably need to perform a firmware upgrade. That particular error code ‘AB FFD0E6’ is one that Philips claim can be overcome by this.

Please read the sticky thread on “Philips firmware upgrades, downgrades”, at the top of the forum. This should help you to provide the following information:

  1. How to open the tray mechanically (instructions at bottom of the text). This is necessary to see whether there is a disc already inside.

  2. A link to download the latest firmware version from the Philips site.

  3. How to burn a CD and perform the upgrade.

For starters, let us know your DVDR985 country code number (presumably DVDR985/17), and whether you can get the tray open using the tab slot.

Thank You for the Info! I will download the latest firmware tonight and try and see if I can get the machine to at least open the tray. Right now none of the buttons on the machine respond or even beep when pushed. I did try the system test by holding the play button down and plugging in the power. After a few trys it worked and passed. After that the machine would respond and turn on. After setting the time and date it errored out again and would not respond. I unplugged it last night and desoldered one lead from the backup battery or capacitor and hopefully I can get it to work later. Hopefully it will not stop working in the middle of upgrading the firmware…
Thanks again!!

Thanks for the PM with the updated information, and it looks like you eventually got the tray open and did the firmware upgrade. Although it appeared to work for a short while by playing a commercial DVD, I’m sorry to say that with the reoccurrence of the same error message it does look like bad news for your machine. Although Philips claim that the AB FFD0E6 error is removed by a firmware upgrade, there are some machines for which this still won’t work. It sounds to me like the firmware upgrade went all right - even though it’s difficult to say because the machine is not working - so it may be that this machine is one of the tough ones and has a more serious fault.

The ‘AB’ error means it’s a fault in the analogue board, and with that persistent error the only way to get your machine repaired again is to have it done by Philips themselves. Usually no parts are available to independent repair shops, unless they have an old model they can cannibalise for spares.

BTW I’m assuming that your machine is no longer under guarantee?

I am afraid not. It is a 2002 Model. I might try one more thing before I look for a machine that I can steal the analog board from. I have read that If you use the universal firmware sometimes it will fix the AB error code. It is funny because I can leave at on for hours with it showing the menu and it will be fine. When I use the DVD player is when I get the code… Thank You for your help!!!

The universal firmware may well just contain the same specific DVDR985/171 firmware packaged along with all the other DVDR models, and hence its size. BTW, when the machine is on and is useable, can you have a look and post the firmware that it’s currently got installed? See the firmware sticky for how to do this.

There’s no definite information available about the details of the ‘AB FFD0E6’ error, but it seems to be linked to the OPU performance (Optical Pickup Unit - a.k.a. the laser). That’s one of the reasons why it seems to fail when you ask it to read a disc. Replacing just the analogue board may not be the answer.

I am sorry that I did not get a chance to check the firmware version after the update from Philips. The version before the upgrade was FF9h. I will post the results of last nights update later. I will try the universal this weekend and see if it will accept the update. I believe that the Universal is FF12t. Maybe I will clean the lens on the pickup but from looking at the air filter and the fans, the machine had hardly been used…

Thanks again!!

That’s OK - I usually think of these things afterwards too ;).

I believe the latest firmware for the 985 is ff12x: see if you can locate that somewhere.

Also, the OPU problem may be more fundamental and linked to the cement holding the lens in place, but if you’ve got the top off then perhaps you could check the seating of any OPU-related ribbon cables in their sockets. I know a few DVD players (not necessarily Philips) where that has been a problem.

Good Evening, I have been playing with the DVDR985 while reininstallings Windows XP in my daughter’s computer that got hit with a virus. I checked the firmware version that is now installed and it is FF12X. I have been able to play audio CD’s, VCD and SVCD fine on it but when I tried DVD’s it errored out. I did look at the lens and it looks clean but did not check to see if it is loose. Do you think I should try and go back to firmware FF12W? Maybe the DVD laser is going bad. It would be easy to go to ff12w. Easier and less expensive than trying to find a laser assembly. I am enjoying learning about all the fun the Philips units provide for their users. Thanks again!

Glad you’re enjoying the experience… :wink:

The reason that CD-based media will play without problem is that the OPU has two lenses; one for CDs and one for DVDs. What you’ve reported is compatible with the DVD lens malfunctioning, but it’s difficult to make an accurate diagnosis of why that is. I wouldn’t expect the lens to be ‘loose’ as such, but more misaligned due to the cement softening over time.

You could try going back to ff12w*. Perhaps that suppresses the error reporting even though the mechanics of the drive are not right. You don’t have much to lose.

Well, I have good news to report… As I said it played CD’s and VCDs A ok. The good news is I put a blank DVD+R in the machine and pushed the record button. Let it record a movie on SP mode for two hours. Finalized the DVD and played it one another player and it was fine. I did not get a chance to play it on the Philips machine but as long as it records, I am happy. Maybe the grease on the sliders or something has gotten hard over the years of no use and playing a couple of CD.s got it soft again. I might just take out the whole assembly to clean and lube it up. Next step is to hook up my DV camcorder to it and copy some of my home videos to DVD. That is the main purpose I have the machine. Have to get a DV to DV cable and I will be all set. PS, I left the firmware at ff12x. So far so good!! Thank you for you knowledge and help!

Well that’s great news - if it hadn’t been used for ages then I suppose that could be the simple answer.

Just as a side-note: +R discs are less reflective than +RW and pressed DVDs, and a common pattern in the history of failing Philips machines is that +R become unreadable first. The fact that your 985 seems to be now handling these fine at the moment is encouraging.

Good luck and let us know how you get on.

Here is an update to my saga of the DVDR985. I bought a DV to DV cable so I could copy my digital video from my camcorder to DVD. Of course the cable did not work. It s wires straight through. I took the Philips apart and uplugged the cable from the front panel (CAM3) and plugged it into the camera. Recorded 1 hour from the camcorder successfully. Added the title and proceeded to copy another hour on the DVD to fill it up. Ran about 20 minutes and thene the machine locked up with a DV error code. Let the machine sit unplugged for a couple of hours and Pushed the play button to do a self test. all was fine. Reset the machine and tried to read the DVD that the machine had locked up while recording. It was not readable. I started again recording the same DV tapes. Worked fine for the first hour. Let the machine sit for a couple of hours and recorded the second tape. All went well. finalized tha disk and seems to play OK on my Apex player. Seems to freeze a little when playing on the DVDR985. I whish there was a jumper that I could set to clear the error code rather than letting the machine sit for a long time.

Thank goodness, there is a topic about the error message of the dvdr985.

Hello, im from holland and we bought a dvdr985 in september 2002. It was functionally perfect untill i changed the firmware, what i did get from the official philips site. After the firmware change i did get exactly the same problems as the topic starter only with an other error code and after a couple of hours disconnection from electricity it was operating again. Only the problem did get back every time

I have now firmware ff12x and i don’t know what firmware was on it before I changed it. Is it possible to put an earlyer firmware on the dvdr985? and does somebody know which firmware it could have been?

thanx in advance, Cezus

Ive tryed after some search to put on an other firmware version: ff12R. after this it is only giving more errors and allways the same code: DB 7FE1F87C

I suggest that this is a Database problem because of that DB for the code…

I hope that someone can help me with this? if i am correct then this is also the errorcode i always did get with firmware ff12x…