Philips DVDR80 Latest Firmware?

vbimport

#1

Hi - I have a Philips DVDR80, does anyone know how I can get hold of the latest Firmware patch for this machine, and the procedure for installing it??

I remember it being posted on the Old Forum awhile back, but cannot retrieve it.

Also has the DVDR80 now been discontinued?? I only got it 18months ago. :eek:


#2

Look here: http://www.dvdplusrw.org/Article.asp?mid=8&sid=10&aid=54

The installingprocedure is there too.


#3

This is not the latest firmware. For the latest firmware go to: http://www.p4c.philips.com/files/d/dvdr80_17/

Download the zip file which should have the directions.


#4

Okay thanks I’ve done this, but when I put the CD in it says Error Disc?? Is it because I used a CD-RW? Although the install instructions say you can use this type of disc. I am currently on BASE_SYS_20030821_FF15f 20030822_0430 vp Firmware.

It should tell me if I don’t need to update, shouldn’t it?


#5

You did burn in using iso9660 mode 2/XA, didn’t you?

This is not very common any more (the latest Roxio can’t do it).

Yes, if you don’t need the update it’ll say up-to-date.


#6

The latest firmware for the DVDR80 is FF16k.

The download page is http://www.p4c.philips.com/files/d/ and you need to select the firmware for your region - the last 2 or 3 digits of the reference. I don’t know where you reside, but the UK is 051.

I have always used CD-R’s, but the burning instructions, included in the download, must be followed, especially with regard to the CD file system.


#7

I’m trying to follow the instructions at http://www.p4c.philips.com/files/d/dvdr80_051/dvdr80_051_fur_eng.pdf but where it says; Write the extracted files onto a blank CD-R or CD-RW disc, using the following settings;

File system CD-Rom ISO Level 2
Mode 2/XA
Character set ISO 9660
Single Session
Write Speed Low

I know you can do this with earlier versions of Nero i.e. 5.0 but I am struggling to find a way of doing this using Nero 6 Express - does anyone know how you can make this type of disc using Nero 6??? :confused:


#8

Forget Nero ‘Express’ - it tends to hide the more complicated options. Press the ‘Nero’ button at the lower left and then under the ‘New Compilation’ window which appears, you can select the character set and ‘Mode 2/XA’ burning option under the ‘ISO’ tab. Choose ‘No multisession’ in the first tab, and something like 4x as the burn speed.


#9

When I press the Nero button it just brings up a pop-up screen saying visit www.nero.com and find out why Nero 6 is the ultimate CD/DVD burning suite. Can you do this from the Nero StartSmart menu??


#10

You may download fully functional demo version of Nero 6 from Nero website and use it before expiration date to burn the firmware update CD with appropriate settings.


#11

I cannot confirm this, but last time I burnt one of these update disks (ff16k I think), I’m sure it would only update if I left off a text file that came in the release, it was the only .txt file in there & it was the copyright info or revision history, something like that. Leave the file on, error; leave it off, updated without a problem. I’m bloody sure it was something like that…! :confused:


#12

Yes, there were some reports of that happening, but IIRC there’s no way to know unless you try it first the conventional way, and it fails…


#13

It’s crap that Philips would make us go through that large of an exercise just to get the firmware. If you don’t have Nero or something compatable, you are screwed. Instead, call the Philips Customer Care line and work your way through the voice prompts to the repair department. Tell them the problem and ask them to mail you a firmware disk. At first they will try to charge you 10 bucks for it and 10 bucks to ship it in the US if your unit is out of warranty. Start out being really nice and give them some line of BS and ask them to send it for free. If that doesn’t help do like I did and raise hell with them. I got mine for free. Didn’t work, though. The unit is trashed. If you are in the US and you can’t get a burned copy to work or get Philips to send you one, let me know and I’ll send you my copy.


#14

Yes, it’s a pain.

Did you get the disc recently?
What’s the latest timestamp on the files.

Just got a 2nd DVDR80 on closeout and it’s cutting off Over-The-Air recordings (NBC, Denver, Co, USA) with a copy protect message. Interestingly, my older DVDR80 doesn’t have the problem. Both are running the latest firmware from the web site.


#15

Where do I find the time stamp on the files? Not sure what that is.

Check this out… I could not get the machine to read the disk at all. I tried one last attempt and rebooted, leaving it unplugged overnight. Plugged it back in and went through all of the bs that it has to do, such as search for channels, etc. I then put in the disk and it downloaded! Took about 25 minutes for the process. I have not tried a recording but I will tonight . It will play DVD’s now, which it would not do before. I am keeping my fingers crossed. If everything works as it should I will owe a big apology to Philips for bad mouthing this machine as I have been. But I guess a little egg on my face isn’t so bad if I can have a working DVDR again, right? :iagree:


#16

If you put the upgrade disc in a pc and turn on “details mode” you can see the dates the files were created.

The majority of the files will have the same date.


#17

Since updating my DVDR75 to Philips latest downloadable firmware, I have been experiencing no end of problems accessing, playing or recording discs with sporadic, frequent but sometimes irreproducible disc errors or unreocgnisable discs - some new, some old, some made with older firmware, some with new.

Philips Customer Services hopeless - if in warranty do this, when did you purchase, if out of warranty do this etc. Fairly sure problem was result of upgrade but couldnt get an older firmware from them and wasn’t prepared to spend money having a dealer try to identify what might otherwise have been design flaws in software/firmware. Unlikely something had suddenly deteriorated in the DVDR at the same time as I made the upgrade!

Ready to skip the box and buy a Panasonic/Sony replacement. After much hunting, which brought me to this board, I found a downloadable copy of the older firmware ff13k, installed tonight and now my discs seem readable. Trying some overnight long play recordings to check for disc errors but problem seems likely to have been solved.

Thanks all


#18

Hi - well I didn’t upgrade to latest firmware after all, it just wasn’t worth the hassle. Judging from some of the problems you can get by upgrading to the latest firmware, I don’t want a machine that doesn’t work. I think I am only 1 update behind anyway, so it’s no big deal. All I wanted was the smoother fast forward.

Maybe when I’m getting round to buying a combi hard disk/DVD recorder (which may be in the next 18 months or so) I might play about with my DVDR80. Until then, I’ll keep it has it is. :slight_smile:

Cheers for all replies.


#19

UGH!!! I wish I saw this site before I tried to do the firmware upgrade. I got the firmware and instructions from the Philips site, and burned the disk per the instructions. Everything seemed to be going along fine then I got and error. Now the disk is stuck in the tray, it won’t open, and the recorder is completely non functional. I checked the unzipped files that I burned and sure enough there was a test file among them that according to a previous poster shouldn’t have been part of the burned firmware CD. Anyone know how to get the tray to open? Anyone have the old firmware available? Or should I try making another firmware cd with out the text file? Thanks for any help, I use this machine for business and need to get it running again.


#20

It would help if you told us what type of machine you had.

Some 98x’s have a hole beneath the tray which will open it if you insert some strong wire.

Others may have a small button which if moved sideways will release the tray lock.

Otherwise you may have to take the cover off and have a look.

In some cases switching off for half an hour and then powering on at the mains with the ‘Open’ button held in has worked, but IIRC this was for discs without boot information on.

If you tell us what the error message was after you tried to upgrade, then more advice could be given about that.