Philips DVDR615/37 and Copy-protection

vbimport

#1

I have a six-month old DVDR615/37 that I use to record programs off my Time Warner DVR (Scientific Atlanta 8300HD). I’ve been pretty happy with it in that time, especially since I upgraded the DVDR615 firmware (to the 8/10/2005 version). But there is one problem that occurs from time to time that drives me crazy. Here goes…

The unit pauses recording in the middle of a show and reports “Signal is copy-protected, record is not possible.” Even worse, once this message appears, I cannot get it to record anything else (even the exact same video signal that I’ve recorded just a few moments earlier). In fact, nothing will record at all until I actually pull the power plug and let it sit for 10 seconds before powering it up again. This is the ONLY thing that resets the unit. Power-cycling using the power button does absolutely nothing.

Now, I know the manual says it this unit detects Macrovision. But I’ve tried to copy VHS tapes that I know have macrovision protection, and as soon as I stop trying to record a protected signal, it works fine.

So, based on that evidence (and other experiences, but I want to try and keep this short), I firmly believe there is a serious firmware bug that causes the copy-protection detector to lock–possibly when some stray glitch in the signal is detected.

I’ve emailed Philips and gotten totally useless responses asking me to read their online FAQ (even when I specifically mention that the FAQ doesn’t address this problem).

Today I spoke with a Philips customer service operator. When I explained the problem he said “yes, we know of that, and that’s what the device is supposed to do”. Incredulous, I asked him again “so you’re saying the user always needs to unplug the dvd-recorder after encountering a copy-protection signal?!?!” and somehow with a straight answer he continued to tell me over and over again: “Yes.”

Well, I was starting to believe (and hoping) that the guy had never even used a DVD-recorder, so I continued to challenge him to produce any documentation that describes that “known behavior”. All he could do was re-read their paragraph in the owner’s manual that mentioned the unit detects macrovision protection. So again, I asked him to support his claim that it was normal proceedure to have to “unplug the recorder” to get it to work again, and he started to blow me off at that point.

So I continued to describe a recent occurance where this happened and about ten minutes later the message went away. Clearly, the unit is sometimes capable of detecting the lack of a protection signal and responding accordingly. A total cold-boot simply can’t be the desired mode of addressing this problem. It seemed like he was starting to understand the problem, but it became clear that his job was to answer the phone and to make people with questions go away…

Anyway, now that I’ve explained my problem. I searched and found this forumn and looked to see if anyone else has encountered or solved it. I didn’t find anything, so I’ve described it to solicit suggestions for a solution.

My first thought is to try a video signal filter to stabilize the signal. I’m using P,B,Y componant inputs (usually with a 480i widescreen signal) and am not sure what stabilizers/macrovision-filters exists. Does anyone have a suggestion for one to buy (one that actually does work and is affordable). Or maybe any other suggestions? I’d appreciate it. Thanks!

Don