Philips DVDR610 displaying "BUSY"

vbimport

#1

Please help me, there was nothing wrong with Philips DVDR610 and suddenly happened this:

DVDR610 displaying “BUSY” on recorder LCD forever when I push play. It happens on any disks (commercial DVD, DVD+R/RW, Audio CD)

If I go to browser mode with DVD disc inside there is “Busy” message on recorder or ‘empty disc’ on tv screen.
If I put epmty DVD and want to record it’s ‘Busy’ again or start recording for few seconds and recorder turn off itself.
If I go to browser mode on audio CD it can read CD contents but with wrong track times (e.g. 1st track 36.00 min, 2nd track 0,00 min 3rd - 15.min 4th - 0.00 min etc.) If I push play recorder shows ‘busy’ again.

Hard reset didn’t help.
I tried to upgrade the firmware but it doesn’t start (it’s ‘busy’). The CD with firmware is recognized as a Audio CD in ‘browser’ mode.

Do you have any ideas?
Thanks in advance.


#2

I have this model as back-up for the unbelievably unreliable Philips DVDR1000mk2 top of the range model and I too have had the problem of the recorder geting stuck in the ‘busy’ mode.
I unplugged the recorder from the mains for 5 minutes and thereafter it worked fine. :wink:


#3

on the firmware issue , make sure your burning a cd rom iso, nero rom essentials is the application to use, also you have to extract twice, once to unzip, then you need to drop and drag the files out off the next folder, don’t burn the disc until you have onlt the files and not the text file.

hope this helps…