Philips DVDR16LS New 1.9 Firmare available

vbimport

#1

Here:
testing now in progress

Get it here.

Modification:

Released 5 August 2005
Improved Lightscribe write algoritm
Improved recognition of sistem restore cd disc

Bye all :slight_smile:


#2

thanks! often the Philips firmwares work better than BenQ or HP for certain of my media, so this comes as a pleasant surprise :smiley:


#3

The media code list of P1.9 is identical to P1.8.


#4

@ala, Any Idea when P1.9 will be Supported by MCSE? +R codes are not showing.

Thanks,


#5

I do not know the when, yet, but P1.9 will be supported in the next release.


#6

@Ala,

Any Ideas why the +R values dont apper? Did they change locations?
Man this 1625 downgrade 0f 16X writting is really pissing me off. You would think that it should be able to function pretty close to the 1620 Specs.

Here is a question? Could the 1625 be crossflashed to 1620, and still keep the lightscribe functionality? Has anyone Tried???

I would be willing to try if none has tried it, but I would like to get some more opinions.


#7

Yes :slight_smile:

Here is a question? Could the 1625 be crossflashed to 1620, and still keep the lightscribe functionality?
You can use a 1620 firmware, but will loose the lightscribe functionality while using the 1620 firmware.


#8

@Ala,

Thats what I thought. Any Idea why 16X and overspeeding has been Locked down tighter than Michael Jacksons Neverland Ranch?

I would think that the 1625 would be more than capable?


#9

Maybe they prefered to sell 1640 drives.


#10

help me please is very important. I have same problem of other member of this forum, but i don’t see a solution. Can you help me. The problem is the same of other members. I install the new philips that work fine for burn cd and dvd, For this any problem. Butthe system not recognize it for lightscribe print label. I’m disperated. I’m going to the shop and i buy other but is the same. I install drivers of LS i reinstall nero, i run nero clean, but NOT WORK. When i’m going to lightscribe options the system said me that i havem’t any drive lightscribe compatible. BUT THIS IS IMPOSSIBLE. The sistem when i install it recognize the right model and show me the name. That’s impossible!!!. I download new firmware (philips said to me) but the problem is the same. Work fine for burn cd dvd but not work for LS. I have windows XP HE. If i install in other computer is possible that’s wor, but i have only one PC and this MUST WORK IN MY PC (that’s new). HELP ME!!!

Claudio
Italy


#11

I have the same problem… but only with Nero.
The solution is Droppix.By the moment i use droppix and lightscribe it´s OK.