Philips DVDR1640 with 16x Philips discs

Hi

I just updated my firmware yesterday to version 3.6 and i tried to burn on a philips 8x disc, but i was able to burn at 12x, i have no problem with that :wink:

But today my new order of 16x speed philips discs arrived so i tried to burn one with DVD Decrypter, but the speed wasn’t higher then 4x :s I can’t figure out what the problem could be, because they’re both philips products…

DVD Decrypter sais this by the information before burning:

PHILIPS DVDR1640P P3.6 (ATA) 
Current Profile: DVD+R 

Disc Information: 
Status: Empty 
Erasable: No 
Free Sectors: 2.295.104 
Free Space: 4.700.372.992 bytes 
Free Time: 510:03:29 (MM:SS:FF) 
Supported Write Speeds: 2,4x; 4x; 8x; 12x; 16x 

Physical Format Information (ADIP): 
Disc ID: RITEK-R05-01 
Book Type: DVD+R 
Part Version: 1 
Disc Size: 120mm 
Maximum Read Rate: Not Specified 
Number of Layers: 1 
Track Path: Parallel Track Path (PTP) 
Linear Density: 0.267 um/bit 
Track Density: 0.74 um/track 
First Physical Sector of Data Area: 196.608 
Last Physical Sector of Data Area: 2.491.711 
Last Physical Sector in Layer 0: 0 

While burning the log says:

...
I 16:47:23 Destination Media Type: DVD+R (Disc ID: RITEK-R05-01) (Speeds: 2,4x; 4x; 8x; 12x; 16x)
...
I 16:47:23 Write Speed: MAX
...

So it says i can burn at 16x, but it doesn’t :s I already inserted the disc as you can see.

I hope someone knows a solution!

thanks!

Ritek R05 is probably not supported in the firmware so it burns it with a generic strategy which is limited to 4x, at least that’s my guess…

I checked what you said, with a tool and you’re right. So i added it with that program :slight_smile: Program came somewhere from this site :smiley: I’m extractin an iso file so i can check it…i hope it works fine…

it’s still not burning at 16x, it peaked at 12x :frowning:

nero 7 also doesn’t burn at 16x, just 12x :s

Perhaps crossflashing it to BenQ firmware would help. I believe your drive is equivalent to the BenQ DW1620. This’ll also make it fully work with Nero cd/dvdspeed.

Just remember that you’ll void the warranty by doing this.

I checked the firmware of the BenQ model and there was also no RITEK 05 in that file to, so i guess that wouldn’t make a difference…maybe it’s just waiting for a news decent firmware then…

First, a late welcome. :wink:

Try with MCSE “Import” function and replace an existing media table you are not using.
There is a short media import guide in that thread… :slight_smile:

If your media is of low quality, the drive will limit your max burn speed anyway. Disabling WOPC might cure this.
.


i tried that, but i didn’t saw Ritek R05 appear, but i also didn’t follow the instruction, i just tried it. I’ll try it tomorrow