Philips DVDR 3595H firmware upgrade problem

vbimport

#1

I have a Philips DVDR 3595H recorder, and numerous attempts to upgrade the firmware have failed.

The recorder, which I bought in November 2007, came with firmware v1.43 installed. Attempts to upgrade the firmware with the various versions which have subsequently become available, either via USB flash disk or CD, have all failed. The recorder initially recognizes the firmware, restarts, begins the upgrade process (as verified by the UPGRADE message in the display), and then displays an “ERROR DL” message. After that, the recorder restarts and the process is terminated with the opening of the disc tray.

I tried again today with the new firmware v3.04 which has just become available, but again without success.

Has anyone else come across this problem? Any assistance would be greatly appreciated.

Antonis


#2

Hi [B]aslicher[/B] and welcome to CD Freaks :slight_smile:

Did you follow the CD instructions all right, and which burning app did you use…?


#3

Glad to join!

I have tried two different USB flash disks, but with the same results each time.

Furthermore, I have tried to install the firmware using a CD-RW (burned using Nero 7 Premium Reloaded), but again with no success.

In each and every instance, I get the dreaded “ERROR DL” message, as described in my first post.


#4

I have the same problem. Need help.

USB-Falsh = Error DL

No more CDs/DVDs could be read :sad:


#5

I just bought a DVDR3570H and have exactly the same issue as aslicher, version 1.43 on the device will not upgrade to latest 3.06 with error ‘ERROR DL’. Device fortunately reboots and is usable.

I think I’ll try calling Philips tomorrow…


#6

I just got mine todya and have the same problem. Upgrade begins, but then it stops with “error dl”

Have tried CD and different USB keys :sad:


#7

For anyone interested, I have finally managed to solve the problem with the help of Philips technical support.

The problem centers around specifying the exact version of the recorder. My recorder is the DVDR 3595H/[B]31[/B] - it is the number after the slash which is important here. It appears that I was trying to install a similar version, but with a different suffix, and that is where the problem lies. Unfortunately, the Philips website is rather vague on this seemingly trivial, but rather important, detail.

If you go to the support and downloads section of the Philips website and enter the exact specification of the recorder, including the number after the slash, in the Search area, you will be provided with a file to download which should match that of your recorder.

In my case, the downloaded file installed perfectly and my firmware is now up to date.


#8

Hi Aslicher,
I joined the forum today specifically to be able to post you a ‘thank you’ note. I came across the forum when I searched for ‘ERROR DL Philips’. Your solution worked for me also. I suppose I could have contacted Tech support but I shouldn’t have had to.
I think the fact that the /31 is not specifically mentioned on the website is appalling. How on earth is anyone supposed to figure that out? Worse still is the fact that they have not added this info since you contacted them.
Interestingly I used to work for Philips in Belgium in the design centre that designed chips (integrated circuits) for their DVD product range. I probably worked on one of the chips in the DVDR3595H. That’s the reason I bought the Philips model rather than a Samsung or other competing model.
I am disappointed in their level of support here.
Once again many thanks. I had visions of the pain in the neck of having to package it up and return it.
Regards,

  • Peter (Alias DukeLamonty)

#9

Peter,

Thank you for your kind words, and glad to be of assistance.

Since posting the solution on this forum, I have contacted Philips with a request to improve their website and be more precise when specifying the firmware required for the DVD-R, or for any other type of equipment for that matter. I am therefore rather surprised to hear from you that this has not yet been done.

Hope you enjoy the DVD-R - the performance of my recorder has improved significantly since upgrading as with v1.43 it had a tendency to crash quite often, whereas now it is much more stable.

Cheers,
Antonis


#10

This is also a THANK YOU note.
You are RIGHT !
I found on the bottom of my DVDR 3595H written on a little paper label that it was in fact the DVDR3595H/31. So, here it is the latest firmware (version 3.06):
[B]http://www.p4c.philips.com/files/d/dvdr3595h_31/dvdr3595h_31_fus_eng.zip

[/B]


#11

gyf
i bought this item apr2008 and also got “error dl” message. with usb and cd-rw also.
the unit was crazy, started up it self and began to record, i tried to disable epg, but no success.

searched google, but found only hispanic forum,
contacted to philps support. but no solution.

yesterday i searched again in google, and found this topic here.
in the unit menu, where the sw version is shown, there is also a type DVDR3595H.
how the h…ll should i know, that there is more than /05 and /51 and /58
so i looked below the unit, there is a sticker, where is written dvdr3595h/31

at last i chose another location, germany and got to the correct /31 page:

where at the top is link to zip download, and eula license agreement window pops up.

i bought it form pixmania.com and had no idea that i must search different sub model from different region :frowning:

to philips:
“if you want them to RTFM, make a better FM”