Philips DVD8601 Slow Read: Any ideas?

vbimport

#1

Hello,

I am hoping someone could shed some light on this seemingly basic problem I’m having with my philips 8601

dvd drive:

  • the drive came with my new Dell dimension 8400

  • the drive reads CD-R material very slowly. It is rated at 40x read speed, but reads at only 60% the speed

of an 8x drive in an old laptop I tested it against. (the test was to copy 350 MB off a CD-R onto the HD.

also the laptop is inferior in all other aspects)

  • I first noticed the drive problem when I was unable to read a CD (game) that has an 8x requirement for the

drive. I presume the cause was that the drive was too slow.

  • Dell gave me a new drive (warranty), but it does the same thing! Another call to Dell tech support

resulted in no O/S problems (I’m running XP) being uncovered.

Any suggestions are greatly appreciated. Thanks!


#2

I have a very unpopular poll out on this forum to help awareness of the read speed issues.
One thing that isn’t mentioned on the poll is the drive’s allergy to Nvidia chipsets. That is caused by an Nvidia driver which can be uninstalled (if applicable). Microsoft’s bundled drivers in XP can well support your drives.
I am aware of no need for 3rd party IDE drivers in a stock system.
If you don’t have 3rd party drivers from the mainboard’s chipset manufacturer, you could test drive them to see if they help. I’ve never seen that, but there’s got to be some reason for their existance. :wink:

ASAPI may not be well installed on your system, but it can be reinstalled.
For most cases, UDMA mode should be enabled in the BIOS, and in some cases, it should be turned off for greater performance. In most-all cases, DMA should be enabled in Windows for both hard drive and CD.

It is possible that your CD data cable is just no good. I experienced this once on my personal computer sitting right on my desk. Sure, the cable looked innocent. . .but it wasn’t!

Some software does not fully support the drive you own. However, there should be at least one case of the drive performing as advertised.

Games may have Safedisc (or similar weak-sector copy protection), and this causes random failures with any optical drive. Sure, it is hard to copy, but it is also generally hard to read. Try a different disc. At least one of your discs should perform to near-advertised specs.

The product is allergic to some media types as is normal for any optical drive. Most rom types work very well. Many, but not all recordables work well. Here’s some that do: Verbatim, Prodisc (not all), CMC Mag (HP BenQ, Phillips), Ritek, Memorex, TDK, Maxell, and many more work very well.

Let us know if any of these suggestions work.


#3

Thanks for the feedback Daniel.

I’ve been looking into some of the ideas you suggested. No solution yet, though I am learning a lot of acryonms…

The latest “feature” I have is that my CD-burning software does not recognize the drive, though I can still read CDs (albeit very slowly). I think that next I’ll uninstall ATAPI and re-install it, as you were suggesting…


#4

Here is how this trouble-shoot ended-up, for anyone with the same problem, or general curiousity:

  • re-installed the OS —> no effect (still can not read the game CD)

  • swapped the Drive again + also the cable (Dell sent me another one!) ------> still no effect

  • bought a $18 ASUS cd-rom drive and installed it in the 2nd bay —> can play the game CD!

  • swapped bays, etc … problem is specific to the Philips 8601 drive, the ASUS can always read the CD.

==> It’s seems that Daniels suggestion about “Safedisc” protection making it difficult for a drive to read games may be happening here. (see earlier post in this thread). Thanks again for your feedback.


#5

Van,

I don’t know if this will make you feel any better, but I have been having the same problem. The drive never really worked properly from the day I got the computer. I spent many hours on the phone with Dell before they finally agreed to send me a new drive–and the new drive is exactly the same!

I don’t know if this is something that happens on all copies of this drive but it is suspicious that you and I both got replacement drives and it still didn’t work. It was so incredibly time-consuming to get the replacement, I suppose some people just give up. I am. I’m going to buy an external USB drive.


#6

Have you guys tried BenQ firmware on these drives?
The manufacturer is faster to release firmware updates than the reseller.
Using BenQ firmware, you would have access to the latest updates (bug fixes) for your drives.


#7

Just to keep others informed:
My Dimension 8400 is currently being investigated by Dell Upper Level Tech Support. The same problems others have detailed. Won’t read SecureROM or Safedisk protected software.

Here’s my theory: since this is a dual layer drive, when it reads the “error” sector from the copy protection, it begins to look for the second layer of a DVD rather than return the appropriate information to the copy protection system. Therefore the drive times out.

I talked with the Dell tech yesterday. They’re now trying to sell it off as a “software issue”. They’ve read these forums. They know what’s going on. This is just a plain faulty drive.

If I get any resolution from Dell I’ll let you know. But currently I’m leaning in the same direction: stick another drive in and start letter writing to Customer Service. This is supposedly their top of the line desktop. A top of the line desktop should read anything you put in it. . .