Philips DVD+-RW SDVD8820

vbimport

#1

Hi, I’m not computer savvy at all. Well, correction, not as much as most of you are I’m sure. I can install programs, do general maintenance and so forth, but as for the hardware information, I have difficulty.

Here’s my dilemma,

I updated my drivers and my Philips DVD Drive decided to not want to read anything anymore. When I contacted Dell (I have an Inspiron E1505 Laptop) they weren’t helpful after waiting 6 hours on the online chat and 2 hours via telephone. They claim that it is working fine by their tests…

So, it doesn’t read DVDs or CDs. The drive opens up, accepts the disc, runs as if reading the disc, but the actual (F:) drive is nonexistent. If you have any suggestions before I attack both Philips and Dell. The hardware says that the driver may be corrupted and or missing as well.


#2

Try in SAFE MODE and clean the drive.

If it wont work, its probably dead.


#3

Were you ever to find a resolution? I am having the exact same problem.


#4

Are you getting an error code in Device Manager? What OS are you using?

Welcome to the forum, BTW :slight_smile:


#5

Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

I’m using windows xp. I’ve uninstalled the driver and then reinstalled and I keep getting the same thing.


#6

OK…there’s a link in my sig about deleting your upper and lower filters, give that a go. :slight_smile:


#7

WHOA! Thank you so much, Arachne! You fixed it!! You are just too cool. Thanks again.


#8

You’re very welcome, glad it worked :smiley:


#9

I joined this forum just so that I too could thank you for the help on this exact same problem. Dell Technical Help decided that I must be wrong or incapable since their suggestions were not working.

Today, as I was becoming resigned to having to purchase a replacement drive, I tried one last search upon the prompting of a friend, and viola!..found this thread and the links in your sig.

Many thanks!!!

BTW, I hope that my posting in a thread that is almost a year old is not considered a fuax pas here on CD Freaks. If so, sorry…but I still am happy I found this article. Did I tell you I was happy…? :D:bow:


#10

Hi everyone,
I got this computer from my friend. The DVD drive (Philips DVD±RW SDVD8820) is not seen in explorer. In the device manager it shows
Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)
But my DMa settings seem correct. even when I ran the vbs specified in this thread - it said all DMA settings are correct.
But I still have problem.
Any other suggestions - where I can get driver, or how to update BIOS settings etc - would be appreciated.


#11

Welcome to CD Freaks. :flower:

Try this… http://support.microsoft.com/kb/314060

Please use the Search Function, as your question either has or may have already been asked. Alternatively, use Google, as Google is usually better at natural searches than the CD Freaks Search Engine. :iagree: All you have to do is type in what you want to find, add “site:cdfreaks.com” to the end of your query, and Google will search the CD Freaks site for your query. :flower:


#12

Thanks. I deleted UpperFilters and LowerFilters registry as specified in the KB article and rebooted system. It is fine now.
Thanks again.


#13

Worked like a charm!!! Many many thanks to you and all your members!


#14

how do i reinstall my philips dvd+rw sdvd8820 after uninstalling it? i don’t want to meddle with it until i received answers from the professionals. cause i’m experiencing the same problem as the other guys so i followed the instructions in this link http://support.microsoft.com/kb/314060. but now my cd drive is not working at all. it says in the link that i have to reinstall the cd recording program when it stops functioning.
please your immediate assistance is highly appreciated!


#15

I to have tried everything explained and it won’t work. Mine however runs CD’s and games. It won’t run DVD’s though. When I insert the DVD the drives clicks and spins around trying to read it, but it does this until I eject the disk. Any ideas???


#16

jmowbray, I’m now having the same problem as you are after initially getting it to work. Now DVDs are treated like CDs or won’t work at all. My system claims not to have a DVD player now. Additionally, I cannot write to blank CDs either. So effectively, I have a CD reader only. Isn’t that just peaches and cream??

What a POS!!!