Philips dvd-rw problem

vbimport

#1

Hi, can someone help me please?
I have installed a new philips DVDR16LS dvd rewriter, and it doesnt work :a
Ok heres the deal: when i turn on my pc the light on the front flashes. After windows starts, it recognises it as it should, DVDR16LS. But it does not recognise any disk that i insert. Also to open the drive i have to insert a paperclip into the manual ejection hole; when i press eject in my computer, or the eject button on the front of the drive, it does not open.
i can give some details, if i forget any please ask:
The drive jumper is set to cable select, and it is cabled as a master, with a cd rw as a slave
I installed the nero oem suite that came with it: but neither nero or my computer can control the drive, but they both recognise it.
in CMOS (setup) the drive is recognised as it should be

I havnt managed to get this drive to work, and i seriously need to. :rolleyes: . . . plz can someone help. . . appreciated :confused:


#2

It is always better to set the drive jumper to master instead of cable select


#3

ty. . . i have now set the drive to master, and the cr rw to slave, but still exactly the same probs. . .help please:(


#4

replace it , its obviously an issue with the drive itself , a drive in good condition will open/close the tray without issues not to mention will recognise discs


#5

thanks, but i cant. . .i bought it when i used to live in england, a couple of months ago. . .im not flying back to england to change it lol. . .but it is in perfect condition. . . if no one suggests anything soon im going to open it up. . . ty :frowning:


#6

please!?!?!? hasnt someone had the same problem? i am desperate!!!


#7

Listen Guy…

It doesn’t make sense that a drive “in perfect condition” doesn’t open its tray.

I also have had numerous drives which had “tray-issues” (mostly Samsung and AOpen). The drives STILL do work, but opening the tray by paperclip…? :disagree: :disagree:

As Easterbunny said earlier, there is just one option. Replace it/RMA it or keep some paperclips handy :o

Good luck!


#8

Try it in a different computer, But I an going to go with a bad drive or cable.
Also make sure it is 80 wire,I disagree about setting to Master…Slave, I have 3 drives in one box and 4 in a different one and all dvds and HDs are CS.
Bruce


#9

ty. . .

lol i love the paperclip handy idea, and i can get the drive open with a paperclip. . . only i still cannot control the drive with my computer. . . .a i can not try it in another computer, as i dont have one :(. . .

the cable im using is 80 wire. . .i have tried setting all to cable select. . .i have tried all jumper settings. . . and i have tried other cables. . . none work lol. . . .i have stripped my pc down and everything in case it was a conflict, but that didnt work. . .i dont know what the problem is, and i am losing hope. . . thanks braynes andSilver Premium. . .appreciate any more suggestionms. . . ty


#10

Just connect the power cable and disconnect the ide cable. If the drive still does not open when you press the eject button, it obviously is damaged.


#11

ty ala42. . .the drive doesnt open with no ide, so i decided to open the drive. . .i have no warrenty, and nothing to loose.
i think the problem is difinetly in the drive. . . .maybe a chip got shorted in the manufacturing. . . all the opening mechanism looks fine, and all the cables are undamaged as far as i can tell… . so its probably a chip.
i know its a bit hopeless to ask for help, but if anyone has any reccomendations i would apriciate . . . .ty


#12

ok, i admit defeat. i have bought a replacement lightscribe dvd rw off ebay, brand new. it should arrive in a couple of weeks, provided that the israeli customs dont blow it up thinking it is nitroglycerin, like they did to a bottle of mango juice once lol.
i dont remember the model, or the brand name, i wil post it when it arrives.