Philips 520h No picture just 'Hello'

I have a philips dvdr 520h, i understand that the same as the Liteon LVW 5045.

I have a little issue of no screen, it powers up with ‘hello’ on the dvd but no picture, created a rom update disc (original from philips) but nothing happens.

There is a jumper on the board jp8, i’m guessing when this is jumpered it goes into some kinf of diag mode, of course i’ve no idea what anything means.

So two things,

  1. Is there a way to kill the current rom and return to original, i.e. if there is an inbuilt backup rom is there a way to force its use?

  2. how to re-install with no screen at all, or do i just chuck it and keep the working h/disk (out of warranty)

BTW i have never had this working got it faulty, the h/disk is good, can see it when plugged into PC, all kinds of crap on it from previous owner unsure if anything specific is supposed to be on there or not, looks like a standard pc dump drive nothing specific looking like a special dir. structure to me. Any ideas if missing anything.

No screen if also if dvd/h.disk removed either. (as not sure if its been fiddled with) Tried another dvd writer was NEC would this work?

Thanks

Steve

It’s difficult to give you guidance if you bought it faulty. No-one knows what happened to it before it came to you.

For a start, please at least give details of what you did to attempt to upgrade the firmware.

As i can’t see the screen all i have done is burn the update to a cd put in the drive. tried to press play but i don’t think the buttons are working as eject doesn’t work. I think it’s knackered but if anyone has any ideas i may as well try em.

Thanks

Steve

Since posting tried again, after burning CD twice more each occasion just pressing ‘ok’ but drive doesn’t spin so I can only guess its not work. Best place to repair in/near peterborough anyone? Also I guess it will need board replacment any idea’s on cost?

Oh if jumper jp8 is jumpered it looks like it goes into a test mode as each key pressed on remote coresponds to a key on the from panel. Any know what they mean or if it can help?

Thanks

Steve

I’m afraid there doesn’t seem much hope for this unit, with DVD drive and screen display gone. There is very little information available outside Philips about the 520H, and seeing as it’s suggested to be a LiteOn product rebadged as Philips, none of the generic Philips solutions (eg factory reset) would be likely to work.

You could try calling ServiceCare in Manchester (see the ‘Philips repair thread’ at the top of the sub-forum page), but even they may not be able to help.

Yes spoke to them they said a flat fee of £129 to fix, which if all those parts are faulty i suppose isn’t that bad. still for that i could probably get something better knowadays.

Will have to think on it.

Thanks

Steve

Im just wondering a freind mentioned that some of the DVD units with a hardisk use a linux cut down installed on the drive.

However no OS on the drive should there be? if so can any create an image or know where i can get one from.

As the drive i beleive was formatted on a PC, could this be the issue?

Thanks

Steve