Philips 420p plasma tv

vbimport

#1

[qanda]This thread is about the Philips Brilliance 420P 42" Plasma monitor. Click here to see full specs[/qanda]Is it often problem wth this monitor (I red in repeair forum), no picture, the red LED blinking after switched on for a few seconds and nothing more.
I downloded the service book and recommended the COMPAIR32 dignose CD to connect with RS232 to PC.
Can anyone help me?
Thanks, email:


#2

Suggest that you remove the back cover and visually check for “puffed up” or “domed” electrolytic capacitors in the power supply. If present, the power supply PCB will need to be removed and the caps in question replaced…a soldering iron will be required. Most Philips plasma products have a “blink code” which, depending on the number of blinks, indicates in what circuit area the problem resides; however, the power supply cap issue described is very common and is worth a shot first.


#3

Thanks, but the red LEd blinks continuisly (until I switch off the monitor).
I chacked (unsoldered a few capacitors mentioned in russian repair forum: http://monitor.net.ru/forum/viewforum.php?f=1, no suscess).

There are suplyies ok in stby power, but no pulses on pins 12, 14 (IC) 7001, but on pin 15 Vcc=8V.
In stby mode must be pulses on 12,14 7001 I think?
but V_cego low (0 V), on pin 10= 2V DC.
Probeably 7001 defect?

Fuse 1004 and 1400 are ok oc course.


#4

Hello. I have the same problem with philips 420p - did you solve the problem ? Can you write me what couse the red blinking?

Sorry for my bad english :wink: