Philips 1640p won't detect most Ritek G04?

vbimport

#1

Hi,

my new-ish 1640p drive won’t detect most of the 9 Ritek G04 DVD-Rs i have here. It burned one just fine a few days ago (it even plays well on other drives), but now the discs usually aren’t detected at all (drive light goes out after a few attempts).

The few times it does detect them, they are unusuable; Qscan fails scanning usually straight away, or sometimes scans OK for ~100secs, then fails (it complains about incompatible firmware, but that’s just the wrong error message for a scan error - it scans other media just fine) - and Nero fails burns as soon as it tries to write (even in simulation), leaving discs blank.

I’ve tried P2.4, P2.5, and the latest BenQ firmwares, no change. I even tried flashing in Safe Mode (although I’m pretty sure that’s just a myth - the flashers verify what they’ve written; if the write failed they would pick it up).

However, a couple of times when flashing, it failed early in the flash, and I had to retry (it then succeeded). Might be related.

Has anyone seen this before with this media or drive? I also have one Datasafe disc it never detects, but I’m also burning a 2.4x DVD+R (CMC MAG R01) successfully right now, and it’s still reading CDs and DVDs OK …

RMA time, flash related problem, or bad batch of discs?


#2

Spoke too soon, the 2.4x write verified very slowly (around ~1meg/sec), and is unreadable on my two drives. And although it will still read DVDs, a lot of burned ones that worked before are reading badly, and occasionally even failing. Looks like the drive is dead.

What’s worrying is that all this happened after I installed the RPC1 patch released yesterday (see my sig). Might just be a coincidence - anybody else had success with the patch?


#3

You might try the dos based flasher and a boot disc to erase the firmware freakout problem. BenQ’s official L9 flasher has also saved a few drives from this issue.
But, I think that yours may be damaged enough that you’ll need the dos-flash method.


#4

Hmm, didn’t help.

What would cause the firmware freakout anyway? The flashers verify what they write, right, so that shouldn’t be it. I believe some other drives (Liteons?) store calibration data - if the BenQ based drives do too, and if that gets trashed somehow, then that would explain it.

I’ll give the BenQ L9 a try, but I suspect it’s the drive…


#5

Nope, L9 didn’t help either.


#6

i’ve the same problem… ritek’s G4 and G5 don’t work! :confused:


#7

How do they fail? Same as mine (drive won’t detect them), or during burning?


#8

That sounds weird? what version of the drive do u have (retail/oem), i have the retail and it seems ok with both these disks under all conditions, why dont you try flashin with the retail firmware to see if that makes a diffrence?
If that dont work have u considerd the fact u might have a faulty drive? if its still under garentee take it back and swap for another 1?


#9

Did you guys (those that had the firmware party) try the dos flash method?


#10

lmfao thats the funniest quote ive heard! :stuck_out_tongue: :stuck_out_tongue:


#11

Hi, mine’s the retail also (1620k). I’m pretty sure the drive is dead - it’s only 2 weeks old, so getting it swapped is no problem. Pain though : ). Thanks for confirming the media should work.

What worries me is that it happened after applying the RPC1 patched fw. It might just be a coincidence, but has anybody else used it without problems?


#12

(it’s my party, and I’ll cry if I want to …)

Daniel, yep, I tried DOS quite a few times now (I once flashed P2.2 3 times in a row, just to be sure : ). No luck. Will get an RMA today.


#13

@gl.tter

my benq only don’t recognise blank g4/g5 discs… very strange :eek:


#14

Ricky, interesting - others have no trouble with G04s, so unless we have a bad batch… It also doesn’t detect my last DataSafe blank (RicohJpn W11), and it has trouble detecting/reading some burned discs reliably that were fine a week ago - so I’m pretty sure it’s the drive.

Interstingly, I just flashed it with P3.0, and it now burns a +RW semi-reliably (the 2nd burn had no errors, the 1st had a couple) - before that particular disc would end up totally riddled with errors. But it hasn’t helped with the other discs : /…

Philips are already sending me a replacement. Gotta love that Philips warranty - they try to get you to take the drive back to where you bought it, but a lot of mail-order places don’t want to play ball (or charge you for testing it). If you tell them that, they’ll courier you a new (refurbished) drive first, and then ask you to courier yours back - all paid for! One reason I went with Philips (the other was the LEDs : ). What’s BenQ’s warranty like?


#15

not bad batch for sure… cos today i bought a new philips 1640 and G4 or G5 works… but not in my original BenQ 1620… note: my philips 1640 is crossflashed for benq 1620!


#16

Right, maybe your drive has the same problem as mine. Did the discs fail straight away, or after (cross) flashing?


#17

ritek disks only fails only in my original benq… not in the philips converted to benq!