PC wont recognize usb 3.0 PCIE

vbimport

#1

Good day

I just bought a usb 3.0 PCIE but my PC wont recognize it :frowning:

could it be because of this in my BIOS

Many thanks


#2

??? :frowning:


#3

According to the ASUS specs, No this Mobo does not recognize 3.0

Expansion Slots
1 x PCIe 2.0 x16
2 x PCIe 2.0 x1
3 x PCI

You will need an adapter card


#4

So u u think i should take it out ?? i asked before i bought it i told the guy even if my mobo does not have usb3.0 he said yes put this in your PCIE slot and it will work

i know the driver out of date for this


#5

Try setting that option for Plug & Play to ‘YES’.

To clarify: you bought the USB 3.0 add-in card, and it’s not being detected? Which add-in card did you buy? Is it PCI, or PCIe? If PCIe, how many lanes (x1, x2, x4, x8, x16) does it need?

Are there any other settings that maybe disable PCI or PCIe slots?


#6

I am not sure but here is the product number of the Hardware

LogiLink PC0054A this is what i have when i first installed it it worked on my thump drive but maybe coz i unplugged it and plunged it back several time it broke


#7

Did it really initially work? If so, try to reseat the card, make sure everything is connected properly, maybe try a different PCIe slot. If that doesn’t help, then it could have been a bad card, yes.


#8

It working now but only one of them work as you know it comes with 2 usb3 any way that good enough for me

would you Like to hear what is more funny then this , after i posted i said to my self let me just go out and get me a 4 port usb 2 witch i know should work on my MOBO so i buy it put it in the usb 3 starts working and the usb 2 doesnt work at all coz it only support windows vista hmmmmmmmmm i am a newbi but isnt this crazy a Little Bit

you tell me :slight_smile:


#9

The usb 2 4port is PC0041

here is the Link to all the drivers and this usb 2 only supports xp/vista/2000 how is this i dont get it please look

http://www.logilink.info/content/support/download.htm?isu_zeigeartikel


#10

I have had three different PCIe x1 express cards in my Desktop over the years, I have NEVER had one automatically install the drivers.

Never had one successfully find the drivers searching on the web

Even when feeding it the driver disc when it asked.

Every single time I’ve had to manually go into device manager manually
select “Update driver”, then manually select “Search in a specific place”
(And specify the driver disc in the optical drive)

What is this nonsense about the motherboard recognizing USB3.0?
That’s the point of a PCIe card!

FWIW the current four port card (Two external and two internal) I have
is the first USB3.0 card I’ve had that worked near or at it’s advertised speed…

But still If I need to do a large write operation either too or from
an external drive I tend to use eSATA.


#11

my pcie 4 port usb 3.0 had a molex power connector on it , don’t think it would work without the molex power being supplied to it. still had to install the drivers that were on the cd as well.


#12

Oh, yes, and my computer has “lost” my current four port USB3.0 PCIe card half a dozen times.

Last night I actually had to, shut down, physically remove the card
reboot, delete the driver shut down again, reinstall the card and
reinstall the driver THEN reboot again for the USB ports connected
to that card to recognize that either of the 4Tb externals connected
to it to be recognized.

I can always tell when the computer cannot find the card, because on rebooting the boot “hangs” just after it displays the desktop and the mouse remains frozen for 75-90seconds.

this is NOT something that makes me happy when I have
a computer with an SSD system drive