PC won't recognise DVD in drive (3:10 to Yuma)

I’m trying to burn this movie, and when i pop it in my DVD burner on my computer, it wont even read it. I’ve tried opening it with a few different programs and nothing. Any ideas on why this is happening and how to fix it?

Search, keywords 3:10 to Yuma or look at the bottom of this thread.

I read through some of those, but my problem is that my dvd burner wont even recognize the dvd is in there. Still any ideas?

So what programs have you tried and what versions? DVDFab HD Decrypter (latest beta) and FixVTS should handle this one with ease.

Are you having any other issues with the drive?

Have you tried reinstalling the drive?

Have you tried updating the firmware for your drive?

Download NeroInfoTool, run it and gives us more specifics about your drive.

http://www.iomagic.com/downloads/utilities/NeroInfoTool_207.zip

What OS are you running?

Does you device manger tell you that your drive is working properly?

:cool::cool:

I just d/l Nero Info tool, what info do you need?

Drive and media info if possible.