PC Rebooted while updating LG4163B to A105

vbimport

#1

Well, I am just a little unlucky guy that got his drive fried in the mean time.

I would like to know is there any firmware extractor out there
such that I can extract the firmware out of the auto updater and flash my drive back to life with mtkflash in dos mode.

Thanks in advance.


#2

I had a problem when I flashed to 105 on my 4163b. Unlike your event, my computer did not reboot, but the flashing program failed to complete, would not exit properly and I reluctantly had to hit the rest button as the computer would not shut the program down to restart.

While I believed it was likely that I lost the drive… when I got back into XP the new hardware wizard redetected the drive… something I see whenever the firmwares are updated. As I knew the rom was not entirely finished flashing before the program failed, I ran it a second time… this time 105 completed and the program finished with the proper option to reboot.

Try running it again… might work for you too. I hope!


#3

@Roland B Same thing happened to me but it happened again the second time so I went back to 104 and it finished properly. I am going to dl another copy of 105 and try again to see if it was the fw was screwed but for now I AM JUST BREATHING BETTER THAT ITS WORKING AT ALL.


#4

Hi,

if you downloaded the A105 from the official LG site then it should be compressed with zip. If so, the chance that there will be ‘random’ corruption which you will not know about if you are using any decent archiver (WinAce, WinRAR, 7zip, WinZip, PKZip etc, not sure about Windows Zip folders) is very very small. The reason is because most archives including Zip store a checksum for each file (usually CRC32, e.g with Zip). The decompressor should (and with a decent archiver does) test the checksum of every single extracted file to make sure it matches the stored checksum. If it does not, it will tell you and you will know the file is corrupt. Therefore assuming you used a decent archiver, it is very unlikely to file is corrupt.

It is far more likely that there is a different problem. The fact that A104 works but A105 doesn’t is a bit strange but it is easily possible LG updated their firmware writing tool. I would recommend you folllow their instructions exactly (read the readme) for example, make sure it is standalone as a master. I would also recommend you try your mobo chipset IDE controller not any Raid controller provided by an external chipset (whether on a card or on your board). Of course, if you are already doing this and following the instructions, maybe try an external chipset IDE controller (if you have one).

MTKflash will never work since it is for Mediatek chipsets!


#5

I always flash the firmware under safe mode that way most problems are avoided as there are no extra drivers or software running in the background that could cause problems or crash the flasher program.


#6

Tried 105 for the third time. Still locked up and didn’t finish but I noticed it said 105 when I rebooted so I burned a few disks and they came out very well so I guess what needed to be completed was. Leaving it this way and keeping a eye on it.


#7

amd950 Did you even try if the drive is still recognised?


#8

I annually flash hundreds to thousands of times but never encountered a drive failure. Most times, under plain Windows XP GUI. Can’t say I’m lucky.