Patched LiteOn iHASx24Y firmwares available

vbimport

#1

I have been busy during the last days modifying Binflash to allow the flashing of LiteOn OEM drives based on the Optiarc AD-7240S/AD-7241S series and now I can finally announce the release of several patched firmwares – including those for the LiteOn drives. The following firmwares are avaible:

[ul]
[li]LiteOn DH24AYS firmwares BP5X and BP5Y
[/li][li]LiteOn DH24AYL firmwares ZP5W, ZP5X and ZP5Y
[/li][li]LiteOn iHAS124Y firmwares BL0V and BL0X
[/li][li]LiteOn iHAS224Y firmwares ZL0W, ZL0X and ZL0Y
[/li][li]LiteOn iHAS324Y firmwares BL1W, BL1X and BL1Y
[/li][li]LiteOn iHAS424Y firmwares ZL1U, ZL1V and ZL1W
[/li][/ul]

All firmwares have bitsetting, RPC1 and auto-reset patches.


#2

[QUOTE=Liggy;2476357]I have been busy during the last days modifying Binflash to allow the flashing of LiteOn OEM drives based on the Optiarc AD-7240S/AD-7241S series and now I can finally announce the release of several patched firmwares – including those for the LiteOn drives. The following firmwares are avaible:

[ul]
[li]LiteOn DH24AYS firmwares BP5X and BP5Y
[/li][li]LiteOn DH24AYL firmwares ZP5W, ZP5X and ZP5Y
[/li][li]LiteOn iHAS124Y firmwares BL0V and BL0X
[/li][li]LiteOn iHAS224Y firmwares ZL0W, ZL0X and ZL0Y
[/li][li]LiteOn iHAS324Y firmwares BL1W, BL1X and BL1Y
[/li][li]LiteOn iHAS424Y firmwares ZL1U, ZL1V and ZL1W
[/li][/ul]

All firmwares have bitsetting, RPC1 and auto-reset patches.[/QUOTE]

Brilliant! :flower: Great work Liggy :clap:


#3

[QUOTE=cvs;2476368]Brilliant! :flower: Great work Liggy :clap:[/QUOTE]
Thanks again for your patience while testing Binflash :flower:


#4

Thank you! :flower:


#5

Liggy,

Thanks again for the iHAS124Y firmware updates. Please disregard an earlier post where I was whining about not being able to unzip a couple of your new firmwares. I downloaded them again and they both unzipped famously. I am happy as a clam at high tide.

Thank you
Thank you
Thank you

pilgrim


#6

I just flashed my iHAS124Y and now it doesnt read anything, can someone help me.

edit: and my pc will sometimes freeze when I pop in a dvd


#7

Do you have to use Binflash with these?


#8

[QUOTE=G_Ivan Awfulitch;2476470]Do you have to use Binflash with these?[/QUOTE]

Yes. For the Lite-On drives that are rebadged Optiarcs, you need Binflash 1.49 or later.

What else would you use but Binflash? Traditional Lite-On utilities can’t communicate with NEC chipset drives. Official firmware updaters from Lite-On can’t load firmware that isn’t bundled with them. Voila.


#9

[QUOTE=iamn1ck;2476452]I just flashed my iHAS124Y and now it doesnt read anything, can someone help me.

edit: and my pc will sometimes freeze when I pop in a dvd[/QUOTE]

Was the freezing before or after the firmware update?

Did you make sure to load the firmware for your EXACT model of drive? Tell us exactly which file you downloaded.


#10

[QUOTE=negritude;2476476]Was the freezing before or after the firmware update?

Did you make sure to load the firmware for your EXACT model of drive? Tell us exactly which file you downloaded.[/QUOTE]

It was after the firmware update to the bitsettings one.

First I flashed it to iHAS124y_bl0xbt_orig, restarted, then it froze when I put in a DVD
Second, I flashed it back to the original BL0X, restarted it worked fine
then I repeated step one (same results)
then i repeated step two (same results)

I think I’ll try iHAS124y_bl0xbt_rpc1


#11

Liggy, I tried to dump stock ZL1W (iHAS424 Y) with Binflash v1.49 in both regular and safe modes (WXP Pro), but both came up with “Error reading firmware from drive” and “Error while dumping firmware” messages. I wanted to try reading first before writing. Any suggestions?


#12

[QUOTE=iamn1ck;2476477]First I flashed it to iHAS124y_bl0xbt_orig, restarted, then it froze when I put in a DVD
Second, I flashed it back to the original BL0X, restarted it worked fine
then I repeated step one (same results)
then i repeated step two (same results)

I think I’ll try iHAS124y_bl0xbt_rpc1[/QUOTE]
This sounds like there could be a bug in one part of the bitsetting code. I must check that again later. For now I’ve taken that firmware offline again.

[UPDATE]Corrected firmwares are online again[/UPDATE]

[QUOTE=KTL;2476488]Liggy, I tried to dump stock ZL1W (iHAS424 Y) with Binflash v1.49 in both regular and safe modes (WXP Pro), but both came up with “Error reading firmware from drive” and “Error while dumping firmware” messages. I wanted to try reading first before writing. Any suggestions?[/QUOTE]
Could you please run the Binflash commandline version and create an identity file? This sounds like your bootcode version is not 0L1Z. What output is given in the Binflash GUI detail window?


#13

Hi Liggy,

I have a same problem with iHAS424 Y (ZL1W).
“Error reading firmware from drive” and “Error while dumping firmware”. The Binflash identity file content is:

— Start of identification —
Version: 1.49
Normal : ATAPI - iHAS424 Y - ZL1W
Boot : ATAPI - iHAS424 Y - 0100
ATAPI*******************DH-24AYL
0000000800000000000000000000000000000000000000000000000000000000
5032343547323436304C315AXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX00FF0000
00000000000000000000000B000000000000000000000000000000001BXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXFFFFFFFF
FFFFFFFFFFFFFFFFFFFFFFFF
— End of identification —


#14

[QUOTE=abo4;2476695]Hi Liggy,

I have a same problem with iHAS424 Y (ZL1W).
“Error reading firmware from drive” and “Error while dumping firmware”. The Binflash identity file content is:[/QUOTE]
That’s strange. Your drive has bootcode 0L1Z and that one should be treated correctly by Binflash :confused:

What output do you get in the detail window (where it lists some version information after starting)?


#15

Hi Liggy,

The output of the detail window is:

GUI version v1.49
Drive interface v1.34
NEC interface v1.49
NEC internal v1.49


#16

Identity file.


--- Start of identification ---
Version: 1.49
Normal : ATAPI    - iHAS424   Y      - ZL1W
Boot   : ATAPI    - iHAS424   Y      - 0100
ATAPI***************************DH-24AYL********
0000000800000000000000000000000000000000000000000000000000000000
5032343547323436304C315AXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX00FF0000
00000000000000000000000B000000000000000000000000000000001BXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXFFFFFFFF
FFFFFFFFFFFFFFFFFFFFFFFF
--- End of identification ---

Binflash GUI details.


Binflash - NEC GUI version - (C) by Liggy, Herrie and r-man
http://binflash.cdfreaks.com

GUI version v1.49
Drive interface v1.34
NEC interface v1.49
NEC internal v1.49

And it’s not copy-and-paste from abo4. :stuck_out_tongue:


#17

[QUOTE=KTL;2476488]Liggy, I tried to dump stock ZL1W (iHAS424 Y) with Binflash v1.49 in both regular and safe modes (WXP Pro), but both came up with “Error reading firmware from drive” and “Error while dumping firmware” messages. I wanted to try reading first before writing. Any suggestions?[/QUOTE]

I just checked, and I get the same two error messages too if I use the SPTI mode. If I want to dump the firmware in ASPI mode, I get the first message only and on clicking OK Binflash closes down. There must be something wrong somewhere …


#18

Could someone test the result with this version? There might have been a bug in the bootcode detection routine. Manually changing the values to what is expected on LiteOn drives in this version seemed to work. Can someone confirm this?


#19

Hi,

I tested with this version, but unfortunately same result:
“Error reading firmware from drive”


#20

Same result as before here as well.